move kernel sound support in its own file from other.mk to sound.mk, rename kmod...
[openwrt/svn-archive/archive.git] / libs / alsa-lib / Makefile
index d27caf0d09b501fe5cae4ed01a6e1f400f9c54e6..0f5d1495a5a47352f53def984ab079059eceb887 100644 (file)
@@ -4,68 +4,82 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alsa-lib
-PKG_VERSION:=1.0.11
+PKG_VERSION:=1.0.13
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/
-PKG_MD5SUM:=ef7ae78a0ef08cbeacb295f2518886ab
-PKG_CAT:=bzcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=d55a9d7d2a79d738a1b7a511cffda4b6
 
 include $(INCLUDE_DIR)/package.mk
 
+ifeq ($(KERNEL),2.4)
+DEPENDS_KMOD:=+kmod-alsa
+else
+DEPENDS_KMOD:=+kmod-sound-core
+endif
+
 define Package/alsa-lib
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+alsa
-  TITLE:=Advanced Linux Sound Architecture Library
-  DESCRIPTION:=This is the library package for alsa, needed by some userspace programs. You must\\\
-       have enabled the ALSA support in the kernel.
+  TITLE:=ALSA (Advanced Linux Sound Architecture) library
   URL:=http://www.alsa-project.org/
+  DEPENDS:=@USB_SUPPORT $(DEPENDS_KMOD)
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,\
-               --enable-shared=yes \
-               --enable-static=yes \
-               --with-gnu-ld \
-               --disable-debugging \
-               --disable-profiling \
-               --with-softfloat \
-               --with-versioned=no \
-)
+define Package/alsa-lib/description
+ This is the library package for alsa, needed by some userspace programs.
+ You must have enabled the ALSA support in the kernel.
 endef
 
-define Build/Compile
-$(call Build/Compile/Default,\
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install)
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-debugging \
+       --disable-profiling \
+       --with-softfloat \
+       --with-versioned=no \
+
+define Build/Configure
+       $(call Build/Configure/Default)
+       $(call libtool_disable_rpath)
 endef
 
-define Package/alsa-lib/install
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasound.so.* $(1)/usr/lib/
+define Build/Compile
+       # override AM_CFLAGS holding inappropriate optimization flags
+       $(MAKE) -C $(PKG_BUILD_DIR) AM_CFLAGS="" all
+       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
 endef
 
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/alsa $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasound.{a,so}* $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasound.{a,so*} $(STAGING_DIR)/usr/lib/
+       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/alsa.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       $(SED) 's,-I$$$${includedir}/alsa,-I$(STAGING_DIR)/usr/include/alsa,g' $(STAGING_DIR)/usr/lib/pkgconfig/alsa.pc
+       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/alsa.pc
+       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/alsa.pc
 endef
 
 define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/alsa \
-               $(STAGING_DIR)/usr/lib/libasound.{a,so}*
+       rm -rf  $(STAGING_DIR)/usr/include/alsa \
+               $(STAGING_DIR)/usr/lib/libasound.{a,so*} \
+               $(STAGING_DIR)/usr/lib/pkgconfig/alsa.pc
+endef
+
+define Package/alsa-lib/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasound.so.* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/share/alsa/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/alsa/alsa.conf $(1)/usr/share/alsa/
 endef
 
 $(eval $(call BuildPackage,alsa-lib))