Add libgcc dependency (#985)
[openwrt/svn-archive/archive.git] / libs / alsa-lib / Makefile
index f8294f6a88ec7d5a1bb616684a6a8d2ae448a276..a4821874f57e0c8714c741ff8ee9ce6a52568b48 100644 (file)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/alsa-lib
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+alsa
+  DEPENDS:=+kmod-alsa @USB_SUPPORT
   TITLE:=ALSA (Advanced Linux Sound Architecture) library
   DESCRIPTION:=\
        This is the library package for alsa, needed by some userspace programs. You must \\\
@@ -35,9 +35,8 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default,\
-               --enable-shared=yes \
-               --enable-static=yes \
-               --with-gnu-ld \
+               --enable-shared \
+               --enable-static \
                --disable-debugging \
                --disable-profiling \
                --with-softfloat \
@@ -46,7 +45,9 @@ define Build/Configure
 endef
 
 define Build/Compile
+       # override AM_CFLAGS holding inappropriate optimization flags
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               AM_CFLAGS="" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
@@ -71,7 +72,7 @@ define Build/UninstallDev
 endef
 
 define Package/alsa-lib/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasound.so.* $(1)/usr/lib/
 endef