replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / libs / alsa-lib / Makefile
index 27ebe81624e153fa48fae169d0f5fe19b5adc1a2..f64579fbe48b4107b3fac830510751bcc728f68d 100644 (file)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/alsa-lib
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+alsa
+  DEPENDS:=+kmod-alsa
   TITLE:=ALSA (Advanced Linux Sound Architecture) library
   DESCRIPTION:=\
        This is the library package for alsa, needed by some userspace programs. You must \\\
@@ -72,7 +72,7 @@ define Build/UninstallDev
 endef
 
 define Package/alsa-lib/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasound.so.* $(1)/usr/lib/
 endef