[package] add mising md5sum check
[openwrt/svn-archive/archive.git] / libs / apr / Makefile
index a9394dc7ac796deff93a4689b6f3588bb5b7b185..a53570a11c1e28c538a3e4707aeb48545cbc1182 100644 (file)
@@ -1,16 +1,15 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$ 
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apr
 PKG_VERSION:=1.2.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://apache.d-s-s-p.de/apr/
@@ -28,17 +27,16 @@ define Package/libapr
   URL:=http://apr.apache.org/
 endef
 
+TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --with-devrandom=/dev/urandom \
        --disable-dso \
        --enable-ipv6
 
 CONFIGURE_VARS += \
-       ac_cv_file__dev_zero=yes \
        apr_cv_process_shared_works=no \
        apr_cv_mutex_robust_shared=no \
        apr_cv_tcp_nodelay_with_cork=yes \
-       ac_cv_sizeof_ssize_t=4 \
        LDFLAGS="$$$$LDFLAGS -lpthread" \
 
 define Build/Compile