[packages] Add missing libtool fixups
[openwrt/svn-archive/archive.git] / libs / argtable / Makefile
index 90e267650f12d18893cad22cf792b2d58d208647..0c5fbadf8aa27cca83d8a3355ca274c907d1fb03 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=argtable
-PKG_VERSION:=2.7
-PKG_RELEASE:=1
+PKG_VERSION:=2.11
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)2-7.tar.gz
+PKG_SOURCE:=$(PKG_NAME)2-11.tar.gz
 PKG_SOURCE_URL:=@SF/argtable
-PKG_MD5SUM:=a84130293aab3bc09631cbee717ede93
+PKG_MD5SUM:=6be6bdb5395b2de8063698f83db61791
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)2-7
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)2-11
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,14 +28,16 @@ define Package/argtable
 endef
 
 define Package/argtable/description
-       Argtable is an ANSI C library for parsing GNU style command line options with a minimum of fuss. 
-       It enables a program's command line syntax to be defined in the source code as an array of argtable 
-       structs. The command line is then parsed according to that specification and the resulting values 
-       are returned in those same structs where they are accessible to the main program. Both tagged 
-       (-v, --verbose, --foo=bar) and untagged arguments are supported, as are multiple instances of 
-       each argument.
+       Argtable is an ANSI C library for parsing GNU style command line options
+       with a minimum of fuss. It enables a program's command line syntax to be
+       defined in the source code as an array of argtable structs. The command
+       line is then parsed according to that specification and the resulting
+       values are returned in those same structs where they are accessible to
+       the main program. Both tagged (-v, --verbose, --foo=bar) and untagged
+       arguments are supported, as are multiple instances of each argument.
 endef
 
+TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -45,18 +48,12 @@ MAKE_FLAGS += \
        all install \
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/argtable2.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libargtable2.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-       $(STAGING_DIR)/usr/include/argtable2.h \
-       $(STAGING_DIR)/usr/lib/libargtable2.{a,so*}
-endef          
-
 define Package/argtable/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libargtable2.so.* $(1)/usr/lib/