[packages] massive: use $(INSTALL_DIR) instead of 'mkdir -p' in install and InstallDev
[openwrt/svn-archive/archive.git] / libs / argtable / Makefile
index ff403c62b57cd71e75a483cc7f01a303a64bbf3d..264a0835fc4dd5efc6197fc4dace1e4c02bc0480 100644 (file)
@@ -8,15 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=argtable
-PKG_VERSION:=2.7
+PKG_VERSION:=2.11
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)2-7.tar.gz
+PKG_SOURCE:=$(PKG_NAME)2-11.tar.gz
 PKG_SOURCE_URL:=@SF/argtable
-PKG_MD5SUM:=a84130293aab3bc09631cbee717ede93
+PKG_MD5SUM:=6be6bdb5395b2de8063698f83db61791
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)2-7
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)2-11
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,14 +27,16 @@ define Package/argtable
 endef
 
 define Package/argtable/description
-       Argtable is an ANSI C library for parsing GNU style command line options with a minimum of fuss. 
-       It enables a program's command line syntax to be defined in the source code as an array of argtable 
-       structs. The command line is then parsed according to that specification and the resulting values 
-       are returned in those same structs where they are accessible to the main program. Both tagged 
-       (-v, --verbose, --foo=bar) and untagged arguments are supported, as are multiple instances of 
-       each argument.
+       Argtable is an ANSI C library for parsing GNU style command line options
+       with a minimum of fuss. It enables a program's command line syntax to be
+       defined in the source code as an array of argtable structs. The command
+       line is then parsed according to that specification and the resulting
+       values are returned in those same structs where they are accessible to
+       the main program. Both tagged (-v, --verbose, --foo=bar) and untagged
+       arguments are supported, as are multiple instances of each argument.
 endef
 
+TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -46,9 +47,9 @@ MAKE_FLAGS += \
        all install \
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/argtable2.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libargtable2.{a,so*} $(1)/usr/lib/
 endef
 
@@ -56,7 +57,7 @@ define Build/UninstallDev
        rm -rf \
        $(STAGING_DIR)/usr/include/argtable2.h \
        $(STAGING_DIR)/usr/lib/libargtable2.{a,so*}
-endef          
+endef
 
 define Package/argtable/install
        $(INSTALL_DIR) $(1)/usr/lib