[packages] argtable: update to 2.12
[openwrt/svn-archive/archive.git] / libs / argtable / Makefile
index a6fc0b7d61614bc268544e44692e3371eaa47cc3..50023d89f1268209d25accdc17d8ab3a30ecb451 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=argtable
-PKG_VERSION:=2.7
+PKG_VERSION:=2.12
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)2-7.tar.gz
+PKG_SOURCE:=$(PKG_NAME)2-12.tar.gz
 PKG_SOURCE_URL:=@SF/argtable
-PKG_MD5SUM:=a84130293aab3bc09631cbee717ede93
+PKG_MD5SUM:=291e249ea60f4d0637e467356a8ae41a
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)2-7
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)2-12
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,12 +29,13 @@ define Package/argtable
 endef
 
 define Package/argtable/description
-       Argtable is an ANSI C library for parsing GNU style command line options with a minimum of fuss. 
-       It enables a program's command line syntax to be defined in the source code as an array of argtable 
-       structs. The command line is then parsed according to that specification and the resulting values 
-       are returned in those same structs where they are accessible to the main program. Both tagged 
-       (-v, --verbose, --foo=bar) and untagged arguments are supported, as are multiple instances of 
-       each argument.
+       Argtable is an ANSI C library for parsing GNU style command line options
+       with a minimum of fuss. It enables a program's command line syntax to be
+       defined in the source code as an array of argtable structs. The command
+       line is then parsed according to that specification and the resulting
+       values are returned in those same structs where they are accessible to
+       the main program. Both tagged (-v, --verbose, --foo=bar) and untagged
+       arguments are supported, as are multiple instances of each argument.
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -40,24 +43,15 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-MAKE_FLAGS += \
-       -C $(PKG_BUILD_DIR)/src \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install \
+MAKE_PATH = ./src
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/argtable2.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libargtable2.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-       $(STAGING_DIR)/usr/include/argtable2.h \
-       $(STAGING_DIR)/usr/lib/libargtable2.{a,so*}
-endef          
-
 define Package/argtable/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libargtable2.so.* $(1)/usr/lib/