fix gmediaserver compile
[openwrt/svn-archive/archive.git] / libs / avahi / Makefile
index ab470233f8b745a09b3ef80b173ebbf59b5528a0..0ad165a402fedd01f60e78100703ffa3c5d29353 100644 (file)
@@ -9,18 +9,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.6.14
+PKG_VERSION:=0.6.16
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://avahi.org/download/
-PKG_MD5SUM:=6abad76bbc2ac0f51a8869b3a2e5c238
+PKG_MD5SUM:=3cbc460bbd55bae35f7b57443c063640
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-PKG_BUILDDEP:=libexpat libdaemon libgdbm
+PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -151,33 +151,33 @@ define Build/UninstallDev
 endef
 
 define Package/libavahi/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-{common,core}.so.* $(1)/usr/lib/
 endef
 
 define Package/avahi-autoipd/install
-       install -d -m0755 $(1)/etc/avahi
+       $(INSTALL_DIR) $(1)/etc/avahi
        $(CP) $(PKG_INSTALL_DIR)/etc/avahi/avahi-autoipd.action $(1)/etc/avahi/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-autoipd $(1)/usr/sbin/
 endef
 
 define Package/avahi-daemon/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-daemon $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/avahi
-       install -m0644 ./files/avahi-daemon.conf $(1)/etc/avahi/
-       install -d -m0755 $(1)/etc/avahi/services
-       install -m0644 ./files/service-http $(1)/etc/avahi/services/http.service
-       install -m0644 ./files/service-ssh $(1)/etc/avahi/services/ssh.service
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/avahi-daemon.init $(1)/etc/init.d/avahi-daemon
+       $(INSTALL_DIR) $(1)/etc/avahi
+       $(INSTALL_DATA) ./files/avahi-daemon.conf $(1)/etc/avahi/
+       $(INSTALL_DIR) $(1)/etc/avahi/services
+       $(INSTALL_DATA) ./files/service-http $(1)/etc/avahi/services/http.service
+       $(INSTALL_DATA) ./files/service-ssh $(1)/etc/avahi/services/ssh.service
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/avahi-daemon.init $(1)/etc/init.d/avahi-daemon
 endef
 
 define Package/avahi-dnsconfd/install
-       install -d -m0755 $(1)/etc/avahi
+       $(INSTALL_DIR) $(1)/etc/avahi
        $(CP) $(PKG_INSTALL_DIR)/etc/avahi/avahi-dnsconfd.action $(1)/etc/avahi/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(1)/usr/sbin/
 endef