[packages] Require* calls must now be placed before BuildPackage calls
[openwrt/svn-archive/archive.git] / libs / avahi / Makefile
index b4f14d57077673361cbb1537021317c5ed303b56..3e8301c78b2f325ff39ebba47cfc1eaf39464a8f 100644 (file)
@@ -1,26 +1,24 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.6.17
+PKG_VERSION:=0.6.25
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://avahi.org/download/
-PKG_MD5SUM:=29ebb2181958d5721ee5fc45f035a77c
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=a83155a6e29e3988f07e5eea3287b21e
 
 PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm
 
+PKG_FIXUP = libtool
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/avahi/Default
@@ -30,6 +28,16 @@ define Package/avahi/Default
   URL:=http://www.avahi.org/
 endef
 
+define Package/avahi/Default/description
+ An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
+ Avahi is a system which facilitates service discovery on a local network --
+ this means that you can plug your laptop or computer into a network and
+ instantly be able to view other people who you can chat with, find printers
+ to print to or find files being shared. This kind of technology is already
+ found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
+ and is very convenient.
+endef
+
 define Package/libavahi
   $(call Package/avahi/Default)
   SECTION:=libs
@@ -39,14 +47,9 @@ define Package/libavahi
 endef
 
 define Package/libavahi/description
-       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
-       Avahi is a system which facilitates service discovery on a local network -- 
-       this means that you can plug your laptop or computer into a network and 
-       instantly be able to view other people who you can chat with, find printers 
-       to print to or find files being shared. This kind of technology is already 
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
-       and is very convenient. 
-       This package contains the mDNS/DNS-SD shared libraries, used by other programs.
+$(call Package/avahi/Default/description)
+ .
+ This package contains the mDNS/DNS-SD shared libraries, used by other programs.
 endef
 
 define Package/avahi-autoipd
@@ -56,19 +59,13 @@ define Package/avahi-autoipd
 endef
 
 define Package/avahi-autoipd/description
-       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
-       Avahi is a system which facilitates service discovery on a local network -- 
-       this means that you can plug your laptop or computer into a network and 
-       instantly be able to view other people who you can chat with, find printers 
-       to print to or find files being shared. This kind of technology is already 
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
-       and is very convenient. 
-       This package implements IPv4LL, "Dynamic Configuration of 
-       IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for 
-       automatic IP address configuration from the link-local 
-       169.254.0.0/16 range without the need for a central server. It 
-       is primarily intended to be used in ad-hoc networks which lack a 
-       DHCP server.
+$(call Package/avahi/Default/description)
+ .
+ This package implements IPv4LL, "Dynamic Configuration of IPv4 Link-Local 
+ Addresses" (IETF RFC3927), a protocol for automatic IP address configuration 
+ from the link-local 169.254.0.0/16 range without the need for a central 
+ server. It is primarily intended to be used in ad-hoc networks which lack a
+ DHCP server.
 endef
 
 define Package/avahi-daemon
@@ -78,14 +75,9 @@ define Package/avahi-daemon
 endef
 
 define Package/avahi-daemon/description
-       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
-       Avahi is a system which facilitates service discovery on a local network -- 
-       this means that you can plug your laptop or computer into a network and 
-       instantly be able to view other people who you can chat with, find printers 
-       to print to or find files being shared. This kind of technology is already 
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
-       and is very convenient. 
-       This package contains an mDNS/DNS-SD daemon.
+$(call Package/avahi/Default/description)
+ .
+ This package contains an mDNS/DNS-SD daemon.
 endef
 
 define Package/avahi-daemon/conffiles
@@ -101,46 +93,62 @@ define Package/avahi-dnsconfd
 endef
 
 define Package/avahi-dnsconfd/description
-       This package contains an Unicast DNS server from mDNS/DNS-SD configuration 
-       daemon, which may be used to configure conventional DNS servers using mDNS 
-       in a DHCP-like fashion. Especially useful on IPv6.
-endef
+$(call Package/avahi/Default/description)
+ .
+ This package contains an Unicast DNS server from mDNS/DNS-SD configuration
+ daemon, which may be used to configure conventional DNS servers using mDNS
+ in a DHCP-like fashion. Especially useful on IPv6.
+endef
+
+TARGET_CFLAGS += $(FPIC) -DGETTEXT_PACKAGE
+
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --disable-glib \
+       --disable-gobject \
+       --disable-qt3 \
+       --disable-qt4 \
+       --disable-gtk \
+       --disable-dbus \
+       --with-xml=expat \
+       --disable-dbm \
+       --enable-gdbm \
+       --enable-libdaemon \
+       --disable-python \
+       --disable-pygtk \
+       --disable-python-dbus \
+       --disable-mono \
+       --disable-monodoc \
+       --disable-doxygen-doc \
+       --disable-doxygen-dot \
+       --disable-doxygen-man \
+       --disable-doxygen-rtf \
+       --disable-doxygen-xml \
+       --disable-doxygen-chm \
+       --disable-doxygen-chi \
+       --disable-doxygen-html \
+       --disable-doxygen-ps \
+       --disable-doxygen-pdf \
+       --disable-xmltoman \
+       --with-distro=none \
+       --with-avahi-user=nobody \
+       --with-avahi-group=nogroup \
+       --with-autoipd-user=nobody \
+       --with-autoipd-group=nogroup
+
+ifneq ($(CONFIG_SSP_SUPPORT),y)
+CONFIGURE_ARGS+= \
+       --disable-stack-protector
+endif
+
+CONFIGURE_VARS+= \
+       CFLAGS="$$$$CFLAGS -DNDEBUG" \
+       $(if $(CONFIG_LINUX_2_4),ac_cv_header_sys_inotify_h=no)
 
 define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-glib \
-               --disable-qt3 \
-               --disable-qt4 \
-               --disable-gtk \
-               --disable-dbus \
-               --enable-expat \
-               --disable-dbm \
-               --enable-gdbm \
-               --enable-libdaemon \
-               --disable-python \
-               --disable-pygtk \
-               --disable-python-dbus \
-               --disable-mono \
-               --disable-monodoc \
-               --disable-doxygen-doc \
-               --disable-doxygen-dot \
-               --disable-doxygen-man \
-               --disable-doxygen-rtf \
-               --disable-doxygen-xml \
-               --disable-doxygen-chm \
-               --disable-doxygen-chi \
-               --disable-doxygen-html \
-               --disable-doxygen-ps \
-               --disable-doxygen-pdf \
-               --disable-xmltoman \
-               --with-distro=none \
-               --with-avahi-user=nobody \
-               --with-avahi-group=nogroup \
-               , \
-               CFLAGS="$$$$CFLAGS -DNDEBUG" \
-       )
+       ( cd $(PKG_BUILD_DIR); aclocal; libtoolize; autoreconf; );
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
@@ -158,12 +166,6 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/avahi-{common,core} \
-               $(STAGING_DIR)/usr/lib/libavahi-{common,core}.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
-endef
-
 define Package/libavahi/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-{common,core}.so.* $(1)/usr/lib/
@@ -173,12 +175,12 @@ define Package/avahi-autoipd/install
        $(INSTALL_DIR) $(1)/etc/avahi
        $(CP) $(PKG_INSTALL_DIR)/etc/avahi/avahi-autoipd.action $(1)/etc/avahi/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-autoipd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/avahi-autoipd $(1)/usr/sbin/
 endef
 
 define Package/avahi-daemon/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-daemon $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/avahi-daemon $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/avahi
        $(INSTALL_DATA) ./files/avahi-daemon.conf $(1)/etc/avahi/
        $(INSTALL_DIR) $(1)/etc/avahi/services
@@ -192,14 +194,15 @@ define Package/avahi-dnsconfd/install
        $(INSTALL_DIR) $(1)/etc/avahi
        $(CP) $(PKG_INSTALL_DIR)/etc/avahi/avahi-dnsconfd.action $(1)/etc/avahi/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(1)/usr/sbin/
 endef
 
+$(eval $(call RequireCommand,intltool-update, \
+       $(PKG_NAME) requires intltool >= 0.35.0 \
+))
+
 $(eval $(call BuildPackage,libavahi))
 $(eval $(call BuildPackage,avahi-autoipd))
 $(eval $(call BuildPackage,avahi-daemon))
 $(eval $(call BuildPackage,avahi-dnsconfd))
 
-$(eval $(call RequireCommand,pkg-config, \
-       $(PKG_NAME) requires pkg-config. \
-))