fix avahi compile on brcm-2.4
[openwrt/svn-archive/archive.git] / libs / avahi / Makefile
index 02d9cceba9366986da7e6fd8955797bf4d10fb9f..a5371d6de4307707f3170a5bc731b7e4350b1e17 100644 (file)
@@ -1,5 +1,6 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.6.17
-PKG_RELEASE:=1
+PKG_VERSION:=0.6.23
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://avahi.org/download/
-PKG_MD5SUM:=29ebb2181958d5721ee5fc45f035a77c
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=aab1a304851d8145ea5f6a85c10af9e9
 
 PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm
 
@@ -28,49 +25,59 @@ define Package/avahi/Default
   SECTION:=net
   CATEGORY:=Network
   TITLE:=An mDNS/DNS-SD implementation
-  DESCRIPTION:=\
-       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).\\\
-       Avahi is a system which facilitates service discovery on a local network -- \\\
-       this means that you can plug your laptop or computer into a network and \\\
-       instantly be able to view other people who you can chat with, find printers \\\
-       to print to or find files being shared. This kind of technology is already \\\
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') \\\
-       and is very convenient.
   URL:=http://www.avahi.org/
 endef
 
+define Package/avahi/Default/description
+ An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
+ Avahi is a system which facilitates service discovery on a local network --
+ this means that you can plug your laptop or computer into a network and
+ instantly be able to view other people who you can chat with, find printers
+ to print to or find files being shared. This kind of technology is already
+ found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
+ and is very convenient.
+endef
+
 define Package/libavahi
   $(call Package/avahi/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+libdaemon +libpthread
   TITLE+= (library)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the mDNS/DNS-SD shared libraries, used by other programs.
+endef
+
+define Package/libavahi/description
+$(call Package/avahi/Default/description) 
+ .
+ This package contains the mDNS/DNS-SD shared libraries, used by other programs.
 endef
 
 define Package/avahi-autoipd
   $(call Package/avahi/Default)
   DEPENDS:=+libdaemon
   TITLE:=IPv4LL network address configuration daemon
-  DESCRIPTION+=\\\
-       \\\
-       This package implements IPv4LL, "Dynamic Configuration of \\\
-       IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for \\\
-       automatic IP address configuration from the link-local \\\
-       169.254.0.0/16 range without the need for a central server. It \\\
-       is primarily intended to be used in ad-hoc networks which lack a \\\
-       DHCP server.
+endef
+
+define Package/avahi-autoipd/description
+$(call Package/avahi/Default/description)
+ .
+ This package implements IPv4LL, "Dynamic Configuration of IPv4 Link-Local 
+ Addresses" (IETF RFC3927), a protocol for automatic IP address configuration 
+ from the link-local 169.254.0.0/16 range without the need for a central 
+ server. It is primarily intended to be used in ad-hoc networks which lack a
+ DHCP server.
 endef
 
 define Package/avahi-daemon
   $(call Package/avahi/Default)
   DEPENDS:=+libavahi +libexpat
   TITLE+= (daemon)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains an mDNS/DNS-SD daemon.
+endef
+
+define Package/avahi-daemon/description
+$(call Package/avahi/Default/description)
+ .
+ This package contains an mDNS/DNS-SD daemon.
 endef
 
 define Package/avahi-daemon/conffiles
@@ -83,50 +90,60 @@ define Package/avahi-dnsconfd
   $(call Package/avahi/Default)
   DEPENDS:=+libavahi
   TITLE:=An Unicast DNS server from mDNS/DNS-SD configuration daemon
-  DESCRIPTION+=\\\
-       \\\
-       This package contains an Unicast DNS server from mDNS/DNS-SD configuration \\\
-       daemon, which may be used to configure conventional DNS servers using mDNS \\\
-       in a DHCP-like fashion. Especially useful on IPv6.
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-glib \
-               --disable-qt3 \
-               --disable-qt4 \
-               --disable-gtk \
-               --disable-dbus \
-               --enable-expat \
-               --disable-dbm \
-               --enable-gdbm \
-               --enable-libdaemon \
-               --disable-python \
-               --disable-pygtk \
-               --disable-python-dbus \
-               --disable-mono \
-               --disable-monodoc \
-               --disable-doxygen-doc \
-               --disable-doxygen-dot \
-               --disable-doxygen-man \
-               --disable-doxygen-rtf \
-               --disable-doxygen-xml \
-               --disable-doxygen-chm \
-               --disable-doxygen-chi \
-               --disable-doxygen-html \
-               --disable-doxygen-ps \
-               --disable-doxygen-pdf \
-               --disable-xmltoman \
-               --with-distro=none \
-               --with-avahi-user=nobody \
-               --with-avahi-group=nogroup \
-               , \
-               CFLAGS="$$$$CFLAGS -DNDEBUG" \
-       )
 endef
 
+define Package/avahi-dnsconfd/description
+$(call Package/avahi/Default/description)
+ .
+ This package contains an Unicast DNS server from mDNS/DNS-SD configuration
+ daemon, which may be used to configure conventional DNS servers using mDNS
+ in a DHCP-like fashion. Especially useful on IPv6.
+endef
+
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --disable-glib \
+       --disable-gobject \
+       --disable-qt3 \
+       --disable-qt4 \
+       --disable-gtk \
+       --disable-dbus \
+       --with-xml=expat \
+       --disable-dbm \
+       --enable-gdbm \
+       --enable-libdaemon \
+       --disable-python \
+       --disable-pygtk \
+       --disable-python-dbus \
+       --disable-mono \
+       --disable-monodoc \
+       --disable-doxygen-doc \
+       --disable-doxygen-dot \
+       --disable-doxygen-man \
+       --disable-doxygen-rtf \
+       --disable-doxygen-xml \
+       --disable-doxygen-chm \
+       --disable-doxygen-chi \
+       --disable-doxygen-html \
+       --disable-doxygen-ps \
+       --disable-doxygen-pdf \
+       --disable-xmltoman \
+       --with-distro=none \
+       --with-avahi-user=nobody \
+       --with-avahi-group=nogroup \
+       --with-autoipd-user=nobody \
+       --with-autoipd-group=nogroup
+
+ifneq ($(CONFIG_SSP_SUPPORT),y)
+CONFIGURE_ARGS+= \
+       --disable-stack-protector
+endif
+
+CONFIGURE_VARS+= \
+       CFLAGS="$$$$CFLAGS -DNDEBUG" \
+       $(if $(CONFIG_LINUX_2_4),ac_cv_header_sys_inotify_h=no)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -134,20 +151,12 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/avahi-{common,core} $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-{common,core}.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/avahi-{common,core} \
-               $(STAGING_DIR)/usr/lib/libavahi-{common,core}.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/avahi-{common,core} $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-{common,core}.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libavahi/install
@@ -159,12 +168,12 @@ define Package/avahi-autoipd/install
        $(INSTALL_DIR) $(1)/etc/avahi
        $(CP) $(PKG_INSTALL_DIR)/etc/avahi/avahi-autoipd.action $(1)/etc/avahi/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-autoipd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/avahi-autoipd $(1)/usr/sbin/
 endef
 
 define Package/avahi-daemon/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-daemon $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/avahi-daemon $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/avahi
        $(INSTALL_DATA) ./files/avahi-daemon.conf $(1)/etc/avahi/
        $(INSTALL_DIR) $(1)/etc/avahi/services
@@ -178,7 +187,7 @@ define Package/avahi-dnsconfd/install
        $(INSTALL_DIR) $(1)/etc/avahi
        $(CP) $(PKG_INSTALL_DIR)/etc/avahi/avahi-dnsconfd.action $(1)/etc/avahi/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,libavahi))
@@ -186,6 +195,7 @@ $(eval $(call BuildPackage,avahi-autoipd))
 $(eval $(call BuildPackage,avahi-daemon))
 $(eval $(call BuildPackage,avahi-dnsconfd))
 
-$(eval $(call RequireCommand,pkg-config, \
-       $(PKG_NAME) requires pkg-config. \
+$(eval $(call RequireCommand,intltool-update, \
+       $(PKG_NAME) requires intltool >= 0.35.0 \
 ))
+