fix avahi compile
[openwrt/svn-archive/archive.git] / libs / avahi / Makefile
index d07168a9e981ee51d55681850bf5c3f85b68a2e9..b4f14d57077673361cbb1537021317c5ed303b56 100644 (file)
@@ -9,18 +9,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.6.14
+PKG_VERSION:=0.6.17
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://avahi.org/download/
-PKG_MD5SUM:=6abad76bbc2ac0f51a8869b3a2e5c238
-PKG_CAT:=zcat
+PKG_MD5SUM:=29ebb2181958d5721ee5fc45f035a77c
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-PKG_BUILDDEP:=libexpat libdaemon libgdbm
+PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,14 +27,6 @@ define Package/avahi/Default
   SECTION:=net
   CATEGORY:=Network
   TITLE:=An mDNS/DNS-SD implementation
-  DESCRIPTION:=\
-       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).\\\
-       Avahi is a system which facilitates service discovery on a local network -- \\\
-       this means that you can plug your laptop or computer into a network and \\\
-       instantly be able to view other people who you can chat with, find printers \\\
-       to print to or find files being shared. This kind of technology is already \\\
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') \\\
-       and is very convenient.
   URL:=http://www.avahi.org/
 endef
 
@@ -43,10 +34,18 @@ define Package/libavahi
   $(call Package/avahi/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libdaemon
+  DEPENDS:=+libdaemon +libpthread
   TITLE+= (library)
-  DESCRIPTION+=\\\
-       \\\
+endef
+
+define Package/libavahi/description
+       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
+       Avahi is a system which facilitates service discovery on a local network -- 
+       this means that you can plug your laptop or computer into a network and 
+       instantly be able to view other people who you can chat with, find printers 
+       to print to or find files being shared. This kind of technology is already 
+       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
+       and is very convenient. 
        This package contains the mDNS/DNS-SD shared libraries, used by other programs.
 endef
 
@@ -54,22 +53,38 @@ define Package/avahi-autoipd
   $(call Package/avahi/Default)
   DEPENDS:=+libdaemon
   TITLE:=IPv4LL network address configuration daemon
-  DESCRIPTION+=\\\
-       \\\
-       This package implements IPv4LL, "Dynamic Configuration of \\\
-       IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for \\\
-       automatic IP address configuration from the link-local \\\
-       169.254.0.0/16 range without the need for a central server. It \\\
-       is primarily intended to be used in ad-hoc networks which lack a \\\
+endef
+
+define Package/avahi-autoipd/description
+       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
+       Avahi is a system which facilitates service discovery on a local network -- 
+       this means that you can plug your laptop or computer into a network and 
+       instantly be able to view other people who you can chat with, find printers 
+       to print to or find files being shared. This kind of technology is already 
+       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
+       and is very convenient. 
+       This package implements IPv4LL, "Dynamic Configuration of 
+       IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for 
+       automatic IP address configuration from the link-local 
+       169.254.0.0/16 range without the need for a central server. It 
+       is primarily intended to be used in ad-hoc networks which lack a 
        DHCP server.
 endef
 
 define Package/avahi-daemon
   $(call Package/avahi/Default)
-  DEPENDS:=+libavahi
+  DEPENDS:=+libavahi +libexpat
   TITLE+= (daemon)
-  DESCRIPTION+=\\\
-       \\\
+endef
+
+define Package/avahi-daemon/description
+       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
+       Avahi is a system which facilitates service discovery on a local network -- 
+       this means that you can plug your laptop or computer into a network and 
+       instantly be able to view other people who you can chat with, find printers 
+       to print to or find files being shared. This kind of technology is already 
+       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
+       and is very convenient. 
        This package contains an mDNS/DNS-SD daemon.
 endef
 
@@ -83,10 +98,11 @@ define Package/avahi-dnsconfd
   $(call Package/avahi/Default)
   DEPENDS:=+libavahi
   TITLE:=An Unicast DNS server from mDNS/DNS-SD configuration daemon
-  DESCRIPTION+=\\\
-       \\\
-       This package contains an Unicast DNS server from mDNS/DNS-SD configuration \\\
-       daemon, which may be used to configure conventional DNS servers using mDNS \\\
+endef
+
+define Package/avahi-dnsconfd/description
+       This package contains an Unicast DNS server from mDNS/DNS-SD configuration 
+       daemon, which may be used to configure conventional DNS servers using mDNS 
        in a DHCP-like fashion. Especially useful on IPv6.
 endef
 
@@ -134,14 +150,12 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/avahi-{common,core} $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-{common,core}.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/avahi-{common,core} $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-{common,core}.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Build/UninstallDev