Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / libs / axtls / Makefile
index c7937ddfd4fec845805a4f86e1b1eeb4035d62f6..d807101715e797b1b76a13610d5513ab7f83d755 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=axtls
 PKG_VERSION:=1.1.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=axTLS-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/axtls http://www.leroc.com.au/axTLS/
@@ -30,6 +30,7 @@ endef
 define Package/axhttpd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Web
   DEPENDS:=+libaxtls
   TITLE:=A small embedded web server using the axTLS library
   URL:=http://www.axtls.co.nr/
@@ -40,6 +41,8 @@ define Build/Configure
        $(MAKE) -C $(PKG_BUILD_DIR) oldconfig
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
@@ -60,7 +63,7 @@ endef
 
 define Package/libaxtls/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libaxtls.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libaxtls.so.* $(1)/usr/lib/
 endef
 
 define Package/axhttpd/install