[package] update check to 0.9.6 (#5368)
[openwrt/svn-archive/archive.git] / libs / check / Makefile
index 22ac2966c445435a98fa391862b4fb0c4ca14318..116ae008f80dbe4cb1ff0c706d97c7a33606cde3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,27 +8,39 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=check
-PKG_VERSION:=0.9.5
+PKG_VERSION:=0.9.6
 PKG_RELEASE:=1
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://dl.sourceforge.net/sourceforge/check/
+PKG_SOURCE_URL:=@SF/check
+PKG_MD5SUM:=6f80cd4a24d14ad706117a7714222420
 PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
-EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include/ -I$(STAGING_DIR)/usr/lib/libiconv/include/ -fPIC
-EXTRA_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/libintl/lib/ -L$(STAGING_DIR)/usr/lib/libiconv/lib/
+PKG_INSTALL = 1
+
+TARGET_CFLAGS += $(FPIC) \
+       -I$(STAGING_DIR)/usr/lib/libintl/include \
+       -I$(STAGING_DIR)/usr/lib/libiconv/include
+
+TARGET_LDFLAGS += \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
 
 define Package/check
   SECTION:=lib
   CATEGORY:=Libraries
-  TITLE:=check
-  URL:=http://sf.net
-  DEPENDS:=+libxml2
+  TITLE:=Unit testing framework for C
+  URL:=http://check.sourceforge.net/
 endef
 
 define Package/check/description
-  unit testinglibrary
+  Check features a simple interface for defining unit tests, putting little in
+  the way of the developer. Tests are run in a separate address space, so Check
+  can catch both assertion failures and code errors that cause segmentation
+  faults or other signals. The output from unit tests can be used within source
+  code editors and IDEs.
 endef
 
 define Build/Configure
@@ -36,10 +48,8 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       cd $(PKG_BUILD_DIR) ; DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) all install
+define Build/Install
+       $(call Build/Install/Default)
        cd $(PKG_INSTALL_DIR)/usr/lib/ ; ln -s libcheck.so libcheck_pic.so
 endef