[packages] mark packages that failed to build on more that 3/4 -rc1 targets as BROKEN
[openwrt/svn-archive/archive.git] / libs / classpath / Makefile
index e7561b0debb23e4ccc9de86e88c03143ea0b12ea..27484f513a8933fc2186d6de1816cd6d647b2680 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=classpath
-PKG_VERSION:=0.97.2
-PKG_RELEASE:=1
+PKG_VERSION:=0.98
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/classpath/
-PKG_MD5SUM:=6a35347901ace03c31cc49751b338f31
+PKG_SOURCE_URL:=@GNU/classpath
+PKG_MD5SUM:=90c6571b8b0309e372faa0f9f6255ea9
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,25 +26,23 @@ define Package/classpath
   TITLE:=GNU Classpath
   URL:=http://www.gnu.org/software/classpath/
   MAINTAINER:=Roberto Riggio (roberto.riggio@create-net.org)
+  DEPENDS:=@BROKEN
 endef
 
-define Package/classpath/Description 
+define Package/classpath/Description
        GNU Classpath, Essential Libraries for Java, is a GNU project 
        to create free core class libraries for use with virtual 
        machines and compilers for the java programming language.
-endef 
-
-CONFIGURE_ARGS+= \
-       --with-javac \
-       --enable-jni \
-       --disable-gtk-peer \
-       --disable-gconf-peer \
-       --disable-plugin \
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               all install
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --with-javac \
+               --enable-jni \
+               --disable-gtk-peer \
+               --disable-gconf-peer \
+               --disable-plugin \
+       )
 endef
 
 define Package/classpath/install