remove UninstallDev
[openwrt/svn-archive/archive.git] / libs / clearsilver / Makefile
index 265e6527149352df3c0b81510c690de8e4a70a53..e1f6ba122101ba79327782ebd18fa755dc18396a 100644 (file)
@@ -22,10 +22,13 @@ define Package/clearsilver
   CATEGORY:=Libraries
   DEPENDS:=+libneon +zlib
   TITLE:=ClearSilver template system
-  DESCRIPTION:=Clearsilver is a fast, powerful, and language-neutral HTML template system. In both static content sites and dynamic HTML applications, it provides a separation between presentation code and application logic which makes working with your project easier.
        URL:=http://www.clearsilver.net/
 endef
 
+define Package/clearsilver/description
+Clearsilver is a fast, powerful, and language-neutral HTML template system. In both static content sites and dynamic HTML applications, it provides a separation between presentation code and application logic which makes working with your project easier.
+endef
+
 CONFIGURE_ARGS += \
   --disable-wdb \
   --disable-apache \
@@ -90,15 +93,6 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/cgi/cs_static.cgi $(1)/usr/bin/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/ClearSilver \
-               $(STAGING_DIR)/usr/lib/libneo_* \
-               $(STAGING_DIR)/usr/bin/cs \
-               $(STAGING_DIR)/usr/bin/cstest \
-               $(STAGING_DIR)/usr/bin/cs_static.cgi
-endef
-
 define Package/clearsilver/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/libs/libneo_cs.a $(1)/usr/lib/