fix curl compile
[openwrt/svn-archive/archive.git] / libs / curl / Makefile
index 1bf08cf2a017686350a9928c9289fb6c7179c87e..0f80736581b3608eee3482485043ff805f8eb8f5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -75,10 +75,20 @@ CONFIGURE_ARGS += \
        --without-libidn \
        --without-nss \
        --with-zlib="$(STAGING_DIR)/usr" \
-       --disable-gssapi
+
+CONFIGURE_VARS += \
+       LDFLAGS="$$$$LDFLAGS -lcrypto -lssl -lz" \
+       CC="$(filter-out ccache,$(TARGET_CC))"
+
+define Build/Configure
+       $(call Build/Configure/Default,,bash)
+endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CC="$(TARGET_CC)" \
+               install
 endef
 
 define Build/InstallDev