[curl]: upgrade to 7.33.0, add myself as maintainer
[openwrt/svn-archive/archive.git] / libs / curl / Makefile
index 6b3492c11aa06189c8df5a978eb970e913cfeecf..2c8f4ffc4981ae45b2efba3d2916d82f25553e1c 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007-2011 OpenWrt.org
+#
+# Copyright (C) 2007-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.21.7
+PKG_VERSION:=7.33.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -19,9 +19,12 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=5f6d50c4d4ee38c57fe37e3cff75adbd
+PKG_MD5SUM:=57409d6bf0bd97053b8378dbe0cadcef
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -30,6 +33,7 @@ define Package/curl/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://curl.haxx.se/
+  MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 endef
 
 define Package/curl
@@ -81,11 +85,11 @@ CONFIGURE_ARGS += \
        $(call autoconf_bool,CONFIG_IPV6,ipv6) \
 
 CONFIGURE_VARS += \
-       LDFLAGS="$$$$LDFLAGS -lcrypto -lssl -lz" \
+       LIBS="-lcrypto -lssl -lz" \
        CC="$(filter-out ccache,$(TARGET_CC))"
 
 define Build/Compile
-       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                CC="$(TARGET_CC)" \
                install
@@ -98,7 +102,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcurl.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_BUILD_DIR)/libcurl.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/curl-config
-       $(if $(TARGET_LDFLAGS),$(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc)
+       [ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc || true
        ln -sf $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
 endef