[curl]: upgrade to 7.33.0, add myself as maintainer
[openwrt/svn-archive/archive.git] / libs / curl / Makefile
index 7716edcf6f9abee27a40aaf932d1a3f6140f707f..2c8f4ffc4981ae45b2efba3d2916d82f25553e1c 100644 (file)
@@ -1,15 +1,14 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.17.1
+PKG_VERSION:=7.33.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -20,9 +19,13 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=1fa635d1dfde8337c98c82749d75c1de
+PKG_MD5SUM:=57409d6bf0bd97053b8378dbe0cadcef
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,12 +33,14 @@ define Package/curl/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://curl.haxx.se/
+  MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 endef
 
 define Package/curl
   $(call Package/curl/Default)
+  SUBMENU:=File Transfer
   DEPENDS:=+libcurl
-  TITLE:=A client-side URL transfer library
+  TITLE:=A client-side URL transfer utility
 endef
 
 define Package/libcurl
@@ -43,7 +48,7 @@ define Package/libcurl
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+libopenssl +zlib
-  TITLE:=A client-side URL transfer utility
+  TITLE:=A client-side URL transfer library
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -58,7 +63,6 @@ CONFIGURE_ARGS += \
        --enable-file \
        --enable-ftp \
        --enable-http \
-       --enable-ipv6 \
        --disable-ares \
        --disable-debug \
        --disable-dict \
@@ -76,18 +80,16 @@ CONFIGURE_ARGS += \
        --without-krb4 \
        --without-libidn \
        --without-nss \
+       --without-libssh2 \
        --with-zlib="$(STAGING_DIR)/usr" \
+       $(call autoconf_bool,CONFIG_IPV6,ipv6) \
 
 CONFIGURE_VARS += \
-       LDFLAGS="$$$$LDFLAGS -lcrypto -lssl -lz" \
+       LIBS="-lcrypto -lssl -lz" \
        CC="$(filter-out ccache,$(TARGET_CC))"
 
-define Build/Configure
-       $(call Build/Configure/Default,,bash)
-endef
-
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                CC="$(TARGET_CC)" \
                install
@@ -100,7 +102,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcurl.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_BUILD_DIR)/libcurl.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/curl-config
-       $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc
+       [ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc || true
        ln -sf $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
 endef