[package] update curl to 7.19.7 (#6151)
[openwrt/svn-archive/archive.git] / libs / curl / Makefile
index 91422c211dab7e3739be41e78ce81ee96653d21f..35c47ed9b0afb8781f668dd84a40498e7a117e46 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.19.4
+PKG_VERSION:=7.19.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=2734167c1e5f7ce6be99b75d2d371d85
+PKG_MD5SUM:=79a8fbb2eed5464b97bdf94bee109380
 
 PKG_FIXUP = libtool
 
@@ -57,7 +57,6 @@ CONFIGURE_ARGS += \
        --enable-file \
        --enable-ftp \
        --enable-http \
-       --enable-ipv6 \
        --disable-ares \
        --disable-debug \
        --disable-dict \
@@ -75,6 +74,7 @@ CONFIGURE_ARGS += \
        --without-krb4 \
        --without-libidn \
        --without-nss \
+       --without-libssh2 \
        --with-zlib="$(STAGING_DIR)/usr" \
 
 CONFIGURE_VARS += \