[package] fix inverted libcurl/curl descriptions (#7648)
[openwrt/svn-archive/archive.git] / libs / curl / Makefile
index 840b7560a7aa2b77f3674db2cda46ec2e3cc4911..411ee0599c025ac50926a7185eaba54beb0e6a50 100644 (file)
@@ -1,15 +1,14 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.19.4
+PKG_VERSION:=7.19.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -20,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=2734167c1e5f7ce6be99b75d2d371d85
+PKG_MD5SUM:=8402c1f654c51ad7287aad57c3aa79be
 
 PKG_FIXUP = libtool
 
@@ -35,7 +34,7 @@ endef
 define Package/curl
   $(call Package/curl/Default)
   DEPENDS:=+libcurl
-  TITLE:=A client-side URL transfer library
+  TITLE:=A client-side URL transfer utility
 endef
 
 define Package/libcurl
@@ -43,7 +42,7 @@ define Package/libcurl
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+libopenssl +zlib
-  TITLE:=A client-side URL transfer utility
+  TITLE:=A client-side URL transfer library
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -58,7 +57,6 @@ CONFIGURE_ARGS += \
        --enable-file \
        --enable-ftp \
        --enable-http \
-       --enable-ipv6 \
        --disable-ares \
        --disable-debug \
        --disable-dict \
@@ -76,6 +74,7 @@ CONFIGURE_ARGS += \
        --without-krb4 \
        --without-libidn \
        --without-nss \
+       --without-libssh2 \
        --with-zlib="$(STAGING_DIR)/usr" \
 
 CONFIGURE_VARS += \