[packages_10.03.1] merge r29498
[openwrt/svn-archive/archive.git] / libs / curl / Makefile
index b424c052ae5e6e3d39bdb37a95857d962f11fd52..806192d0fd2a757451c38bee0bbbf65e816b05ba 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.19.6
+PKG_VERSION:=7.21.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=8402c1f654c51ad7287aad57c3aa79be
+PKG_MD5SUM:=5f6d50c4d4ee38c57fe37e3cff75adbd
 
 PKG_FIXUP:=libtool
 PKG_BUILD_PARALLEL:=1
@@ -34,6 +34,7 @@ endef
 
 define Package/curl
   $(call Package/curl/Default)
+  SUBMENU:=File Transfer
   DEPENDS:=+libcurl
   TITLE:=A client-side URL transfer utility
 endef
@@ -77,15 +78,12 @@ CONFIGURE_ARGS += \
        --without-nss \
        --without-libssh2 \
        --with-zlib="$(STAGING_DIR)/usr" \
+       $(call autoconf_bool,CONFIG_IPV6,ipv6) \
 
 CONFIGURE_VARS += \
        LDFLAGS="$$$$LDFLAGS -lcrypto -lssl -lz" \
        CC="$(filter-out ccache,$(TARGET_CC))"
 
-define Build/Configure
-       $(call Build/Configure/Default,,bash)
-endef
-
 define Build/Compile
        $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \