[package] update libcurl to 7.19.4
[openwrt/svn-archive/archive.git] / libs / curl / Makefile
index 5bb0a0087c1c3d5d657bafdebc8ccea7bc0e6fd9..840b7560a7aa2b77f3674db2cda46ec2e3cc4911 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.17.1
+PKG_VERSION:=7.19.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -20,7 +20,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=1fa635d1dfde8337c98c82749d75c1de
+PKG_MD5SUM:=2734167c1e5f7ce6be99b75d2d371d85
 
 PKG_FIXUP = libtool
 
@@ -100,7 +100,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcurl.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_BUILD_DIR)/libcurl.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/curl-config
-       $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/libcurl.pc
+       $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc
        ln -sf $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
 endef