[package] update libcurl to 7.19.4
[openwrt/svn-archive/archive.git] / libs / curl / patches / 100-cross_compile.patch
index 0f61f05b963cb2fc88f3a5ed42e8338bb2078883..cfe2acf4042b43afeef960099a21a1248eee24ed 100644 (file)
@@ -35,25 +35,25 @@ Index: curl-7.17.1/configure
  fi
  
  
-@@ -27741,18 +27722,6 @@
+@@ -25704,18 +25685,6 @@
  fi
  
--
 -      if test "x$USE_GNUTLS" = "xyes"; then
 -        { echo "$as_me:$LINENO: detected GnuTLS version $version" >&5
 -echo "$as_me: detected GnuTLS version $version" >&6;}
 -
+-        if test -n "$gtlslib"; then
 -
--        LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
--        export LD_LIBRARY_PATH
--        { echo "$as_me:$LINENO: Added $gtlsprefix/lib$libsuff to LD_LIBRARY_PATH" >&5
--echo "$as_me: Added $gtlsprefix/lib$libsuff to LD_LIBRARY_PATH" >&6;}
+-          LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
+-          export LD_LIBRARY_PATH
+-          { echo "$as_me:$LINENO: Added $gtlslib to LD_LIBRARY_PATH" >&5
+-echo "$as_me: Added $gtlslib to LD_LIBRARY_PATH" >&6;}
+-        fi
 -      fi
--
      fi
  
-   fi
 @@ -27951,17 +27920,6 @@
  fi
  
@@ -114,26 +114,27 @@ Index: curl-7.17.1/configure.ac
  fi
  
  dnl **********************************************************************
-@@ -1464,19 +1440,6 @@
+@@ -1610,20 +1586,6 @@
           CPPFLAGS="$CLEANCPPFLAGS"
         ])
  
 -      if test "x$USE_GNUTLS" = "xyes"; then
 -        AC_MSG_NOTICE([detected GnuTLS version $version])
 -
--        dnl when shared libs were found in a path that the run-time
--        dnl linker doesn't search through, we need to add it to
--        dnl LD_LIBRARY_PATH to prevent further configure tests to fail
--        dnl due to this
+-        if test -n "$gtlslib"; then
+-          dnl when shared libs were found in a path that the run-time
+-          dnl linker doesn't search through, we need to add it to
+-          dnl LD_LIBRARY_PATH to prevent further configure tests to fail
+-          dnl due to this
 -
--        LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
--        export LD_LIBRARY_PATH
--        AC_MSG_NOTICE([Added $gtlsprefix/lib$libsuff to LD_LIBRARY_PATH])
+-          LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
+-          export LD_LIBRARY_PATH
+-          AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
+-        fi
 -      fi
--
      fi
  
-   fi dnl GNUTLS not disabled
 @@ -1544,19 +1507,6 @@
           CPPFLAGS="$CLEANCPPFLAGS"
         ])