[packages] cyrus-sasl: add libtool fixup, now it compiles for ppc target as well
[openwrt/svn-archive/archive.git] / libs / cyrus-sasl / Makefile
index d35221cff926c6a87783a9dd89a0da203fe6fe73..8b39cdbddf90d2598752c36957cfee2f4e540658 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -20,6 +20,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DEPENDS:=libopenssl
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -96,12 +97,6 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.{a,so*} $(1)/usr/lib/sasl2/
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/sasl \
-               $(STAGING_DIR)/usr/lib/libsasl{2,}.{a,so*} \
-               $(STAGING_DIR)/usr/lib/sasl2
-endef
-
 define Package/libsasl2/install
        $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.so.* $(1)/usr/lib/