[8.09] merge r17680
[openwrt/svn-archive/archive.git] / libs / cyrus-sasl / Makefile
index 1b1fa37733d6d78c6b9cde6020faaeee9d46a8ed..aac46300b7e7f13bbd7004f444e990184c00a739 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,12 +15,9 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ftp.andrew.cmu.edu/pub/cyrus-mail/
 PKG_MD5SUM:=268ead27f4ac39bcfe17d9e38e0f2977
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-PKG_BUILDDEP:=libopenssl
+PKG_BUILD_DEPENDS:=libopenssl
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,48 +28,46 @@ define Package/libsasl2
   URL:=http://asg.web.cmu.edu/sasl/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-sample \
-               --enable-staticdlopen \
-               --disable-java \
-               --disable-alwaystrue \
-               --disable-checkapop \
-               --enable-cram \
-               --enable-digest \
-               --disable-otp \
-               --disable-srp \
-               --disable-srp-setpass \
-               --disable-krb4 \
-               --disable-gssapi \
-               --disable-gss_mutexes \
-               --enable-plain \
-               --enable-anon \
-               --disable-login \
-               --disable-ntlm \
-               --disable-sql \
-               --with-dblib="none" \
-               --without-gdbm \
-               --with-devrandom="/dev/urandom" \
-               --without-pam \
-               --without-saslauthd \
-               --without-authdaemond \
-               --without-pwcheck \
-               --with-ipctype=unix \
-               --with-openssl="$(STAGING_DIR)/usr" \
-               --without-des \
-               --without-opie \
-               --without-ldap \
-               --without-mysql \
-               --without-pgsql \
-               --without-sqlite \
-               --without-rc4 \
-               --without-dmalloc \
-               --without-sfio \
-       );
-endef
+TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-sample \
+       --enable-staticdlopen \
+       --disable-java \
+       --disable-alwaystrue \
+       --disable-checkapop \
+       --enable-cram \
+       --enable-digest \
+       --disable-otp \
+       --disable-srp \
+       --disable-srp-setpass \
+       --disable-krb4 \
+       --disable-gssapi \
+       --disable-gss_mutexes \
+       --enable-plain \
+       --enable-anon \
+       --disable-login \
+       --disable-ntlm \
+       --disable-sql \
+       --with-dblib="none" \
+       --without-gdbm \
+       --with-devrandom="/dev/urandom" \
+       --without-pam \
+       --without-saslauthd \
+       --without-authdaemond \
+       --without-pwcheck \
+       --with-ipctype=unix \
+       --with-openssl="$(STAGING_DIR)/usr" \
+       --without-des \
+       --without-opie \
+       --without-ldap \
+       --without-mysql \
+       --without-pgsql \
+       --without-sqlite \
+       --without-rc4 \
+       --without-dmalloc \
+       --without-sfio
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/include \
@@ -87,20 +82,14 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/sasl $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.{a,so*} $(STAGING_DIR)/usr/lib/
-       ln -sf libsasl2.a $(STAGING_DIR)/usr/lib/libsasl.a
-       ln -sf libsasl2.so $(STAGING_DIR)/usr/lib/libsasl.so
-       mkdir -p $(STAGING_DIR)/usr/lib/sasl2
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.{a,so*} $(STAGING_DIR)/usr/lib/sasl2/
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/sasl \
-               $(STAGING_DIR)/usr/lib/libsasl{2,}.{a,so*} \
-               $(STAGING_DIR)/usr/lib/sasl2
+       mkdir -p $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/sasl $(1)/usr/include/
+       mkdir -p $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.{a,so*} $(1)/usr/lib/
+       ln -sf libsasl2.a $(1)/usr/lib/libsasl.a
+       ln -sf libsasl2.so $(1)/usr/lib/libsasl.so
+       mkdir -p $(1)/usr/lib/sasl2
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.{a,so*} $(1)/usr/lib/sasl2/
 endef
 
 define Package/libsasl2/install