phidget21: add missing dependency
[openwrt/svn-archive/archive.git] / libs / cyrus-sasl / Makefile
index 2aa86f143ef91a99c4a68550628080998dd7bd91..ca78de83e3cacfcc290db809ece59f0664c8d449 100644 (file)
@@ -16,7 +16,11 @@ PKG_SOURCE_URL:=http://ftp.andrew.cmu.edu/pub/cyrus-mail/
 PKG_MD5SUM:=2eb0e48106f0e9cd8001e654f267ecbc
 
 PKG_BUILD_DEPENDS:=libopenssl
-PKG_FIXUP = libtool no-autoreconf
+
+PKG_FIXUP:=autoreconf
+PKG_MACRO_PATHS:=cmulocal config ../cmulocal ../config
+PKG_AUTOMAKE_PATHS:=. saslauthd sasldb
+PKG_REMOVE_FILES:=aclocal.m4 saslauthd/aclocal.m4
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -68,7 +72,8 @@ CONFIGURE_ARGS += \
        --without-sqlite \
        --without-rc4 \
        --without-dmalloc \
-       --without-sfio
+       --without-sfio \
+       --disable-sample
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/include \
@@ -77,9 +82,6 @@ define Build/Compile
                CFLAGS="" \
                CPPFLAGS="" \
                makemd5
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install || \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install