[packages] zaptel: update and fix kernel module build for 2.6.34
[openwrt/svn-archive/archive.git] / libs / db47 / Makefile
index ff8bd58922c2397c20cdaf9a620805c3706fc10a..6fe56a3fa43ebb5837a70691a2ec7d1c5c26943d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2009 OpenWrt.org
+#
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,16 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=db47
 PKG_VERSION:=4.7.25.NC
-PKG_RELEASE:=1
+PKG_RELEASE:=6
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/db-$(PKG_VERSION)
 PKG_SOURCE:=db-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.oracle.com/berkeley-db/
 PKG_MD5SUM:=073ab7f20d24b3872a51ca762f5090e7
 
+PKG_FIXUP:=libtool
+PKG_LIBTOOL_PATHS:=. build_unix
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libdb47
@@ -59,15 +62,13 @@ define Build/Configure
                        --enable-shared \
                        --enable-static \
                        --disable-java \
-                       --enable-cxx \
-                       --disable-posixmutexes \
-                       --disable-uimutexes \
+                       --disable-cxx \
+                       --with-mutex=UNIX/fcntl \
                        --disable-tcl \
                        --disable-rpc \
                        --enable-compat185 \
-                       --enable-debug \
-                       --enable-statistics \
-                       --enable-replication \
+                       --enable-smallbuild \
+                       --disable-debug \
                        --enable-cryptography \
        );
 endef
@@ -75,8 +76,6 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR)/build_unix \
                DESTDIR="$(PKG_INSTALL_DIR)" install
 endef
@@ -87,10 +86,10 @@ define Package/libdb47/install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/lib/db47/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/db.h $(1)/usr/lib/db47/usr/include/
-       mkdir -p $(1)/usr/lib/db47/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb*.{a,so} $(1)/usr/lib/db47/usr/lib
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/db.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb*.{a,so} $(1)/usr/lib
 endef
 
 $(eval $(call BuildPackage,libdb47))