libs/libiconv: refresh patches
[openwrt/svn-archive/archive.git] / libs / fftw3 / Makefile
index 658bd0d07e54b78544af097e3a37744d154d5a75..5a181d09362b7447eebcf7127447bcf8f3264c38 100644 (file)
@@ -1,28 +1,29 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
-# $Id: $
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fftw3
-PKG_VERSION:=3.1.2
+PKG_VERSION:=3.2.2
+PKG_RELEASE:=2
 
-
-PKG_SOURCE_URL:=http://www.fftw.org/
-PKG_SOURCE:=fftw-3.1.2.tar.gz
-PKG_MD5SUM:=08f2e21c9fd02f4be2bd53a62592afa4
+PKG_SOURCE:=fftw-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.fftw.org
+PKG_MD5SUM:=b616e5c91218cc778b5aa735fefb61ae
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/fftw-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/fftw3
-  SECTION:=Libraries
+  SECTION:=libs
   CATEGORY:=Libraries
+  DEPENDS:=@!avr32
   TITLE:=Fast Fourier transform library
   URL:=http://www.fftw.org/
 endef
@@ -32,9 +33,10 @@ define Package/fftw3/description
        Discrete Fourier Transform in one or more dimensions. It
        includes complex, real, and parallel transforms, and can
        handle arbitrary array sizes efficiently.
-       http://www.fftw.org/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --prefix=/usr \
        --without-libiconv-prefix \
@@ -51,6 +53,14 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/fftw3.h $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfftw3*.{a,la} $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfftw3*.so* $(1)/usr/lib
+endef
+
 define Package/fftw3/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfftw3.so* $(1)/usr/lib/