file:
[openwrt/svn-archive/archive.git] / libs / file / Makefile
index 230ecc4a12b619cde3b310229341df9d5b209a3c..b79b4416520a8d299923f724ced681cdbd93948e 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,10 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.astron.com/pub/file/
 PKG_MD5SUM:=a61ef3aa8339d5987148089afde25f60
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,7 +22,7 @@ define Package/libmagic
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+zlib
-  TITLE:=File type determination library
+  TITLE:=Determines file type using "magic" numbers
   URL:=ftp://ftp.astron.com/pub/file/
 endef
 
@@ -34,26 +30,31 @@ define Package/file
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+libmagic
-  TITLE:=File type determination library
+  TITLE:=Determines file type using "magic" numbers
   URL:=ftp://ftp.astron.com/pub/file/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-               --without-libiconv-prefix \
-               --without-libintl-prefix \
-       )
-endef
+define Package/file/description
+ File tests each argument in an attempt to classify it. There
+ are three sets of tests, performed in this order: filesystem
+ tests, magic number tests, and language tests. The first test
+ that succeeds causes the file type to be printed.
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/src \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+ Starting with version 4, the file command is not much more than
+ a wrapper around the "magic" library. 
 endef
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --without-libiconv-prefix \
+       --without-libintl-prefix \
+
+MAKE_FLAGS += \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install \
+
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/magic.h $(STAGING_DIR)/usr/include/
@@ -75,10 +76,9 @@ endef
 define Package/file/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_DIR) $(1)/usr/share/file
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/file \
-               $(1)/usr/bin
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/magic/Magdir/linux \
-               $(1)/usr/share/file/magic
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/file $(1)/usr/bin
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/magic/Magdir/linux $(1)/usr/share/file/magic
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/magic/magic.mime $(1)/usr/share/file/magic.mime
 endef
 
 $(eval $(call BuildPackage,libmagic))