replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / libs / freetype / Makefile
index 5ac0e392d4a0ff87b0d441637b28a030822aac97..4204a4bcd2a75b3b7052be49604f8b6e249665fc 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=libfreetype
 PKG_VERSION:=2.1.9
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/freetype-$(PKG_VERSION)
 PKG_SOURCE:=freetype-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/freetype
 PKG_MD5SUM:=ec1b903e4be5f073caa72458ea58c29c
 PKG_CAT:=bzcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/freetype-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -27,57 +27,29 @@ define Package/libfreetype
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE:=A free, high-quality and portable font engine
-  DESCRIPTION:=A free, high-quality and portable font engine.\\\
-    The FreeType project is a team of volunteers who develop free, \\\
-    portable and high-quality software solutions for digital typography.\\\
-    They specifically target embedded systems and focus on bringing small, \\\
-    efficient and ubiquitous products.
+  DESCRIPTION:=\
+       The FreeType project is a team of volunteers who develop free, \\\
+       portable and high-quality software solutions for digital typography.\\\
+       They specifically target embedded systems and focus on bringing small, \\\
+       efficient and ubiquitous products.
   URL:=http://www.freetype.org/
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               $(TARGET_CONFIGURE_OPTS) \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --sbindir=/usr/sbin \
-                       --libexecdir=/usr/lib \
-                       --sysconfdir=/etc \
-                       --datadir=/usr/share \
-                       --localstatedir=/var \
-                       --mandir=/usr/man \
-                       --infodir=/usr/info \
-                       $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
-                       --enable-shared=yes \
-                       --enable-static=yes \
-                       --disable-rpath \
-       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+       )
+       $(SED) 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec="$(STAGING_DIR)/usr/lib $(STAGING_DIR)/lib"|g' \
+               $(PKG_BUILD_DIR)/builds/unix/libtool
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libfreetype/install
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(STAGING_DIR)/usr/bin/
@@ -88,6 +60,8 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(STAGING_DIR)/usr/lib/
        mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       $(SED) 's,-I$$$${includedir}/freetype2,,g' $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
+       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
 endef
 
 define Build/UninstallDev
@@ -99,4 +73,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
 endef
 
+define Package/libfreetype/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libfreetype))