Remove UninstallDev template, which is no longer required
[openwrt/svn-archive/archive.git] / libs / freetype / Makefile
index 88ddbf3c526286acebb449fe027f75f29b64336e..7592c8c1a6b33fe7402c954c2bdb74e975acefea 100644 (file)
@@ -9,12 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freetype
-PKG_VERSION:=2.3.1
+PKG_VERSION:=2.3.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/freetype
-PKG_MD5SUM:=11e1186ca5520c5a284fa0a03f652035
+PKG_MD5SUM:=83306194817ebdea554133b4232a34aa
+
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,20 +39,13 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-define Build/Configure
-       $(call Build/Configure/Default)
-       $(call libtool_disable_rpath)
-endef
-
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(1)/usr/bin/
+       mkdir -p $(2)/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(2)/bin/
        mkdir -p $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/freetype2 $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/ft2build.h $(1)/usr/include/
@@ -58,17 +53,10 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(1)/usr/lib/
        mkdir -p $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$$includedir/freetype2,-I$(1)/usr/include/freetype2,g' $(1)/usr/bin/freetype-config
-       $(SED) 's,/usr/include/freetype2/,$(1)/usr/include/freetype2/,g' $(1)/usr/bin/freetype-config
+       $(SED) 's,-I$$$$includedir/freetype2,-I$(STAGING_DIR)/usr/include/freetype2,g' $(2)/bin/freetype-config
+       $(SED) 's,/usr/include/freetype2/,$(STAGING_DIR)/usr/include/freetype2/,g' $(2)/bin/freetype-config
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/bin/freetype-config \
-               $(STAGING_DIR)/usr/include/freetype2 \
-               $(STAGING_DIR)/usr/include/ft2build.h \
-               $(STAGING_DIR)/usr/lib/libfreetype.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
-endef
 
 define Package/libfreetype/install
        $(INSTALL_DIR) $(1)/usr/lib