Remove UninstallDev template, which is no longer required
[openwrt/svn-archive/archive.git] / libs / freetype / Makefile
index a93ae29988de95ea68113ecf2bc88ec6aa88ca07..7592c8c1a6b33fe7402c954c2bdb74e975acefea 100644 (file)
@@ -8,17 +8,15 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=libfreetype
-PKG_VERSION:=2.1.9
+PKG_NAME:=freetype
+PKG_VERSION:=2.3.7
 PKG_RELEASE:=1
 
-PKG_SOURCE:=freetype-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/freetype
-PKG_MD5SUM:=ec1b903e4be5f073caa72458ea58c29c
-PKG_CAT:=bzcat
+PKG_MD5SUM:=83306194817ebdea554133b4232a34aa
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/freetype-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,54 +25,41 @@ define Package/libfreetype
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE:=A free, high-quality and portable font engine
-  DESCRIPTION:=\
-       The FreeType project is a team of volunteers who develop free, \\\
-       portable and high-quality software solutions for digital typography.\\\
-       They specifically target embedded systems and focus on bringing small, \\\
-       efficient and ubiquitous products.
   URL:=http://www.freetype.org/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-       )
-       $(SED) 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec="$(STAGING_DIR)/usr/lib $(STAGING_DIR)/lib"|g' \
-               $(PKG_BUILD_DIR)/builds/unix/libtool
+define Package/libfreetype/description
+ The FreeType project is a team of volunteers who develop free, 
+ portable and high-quality software solutions for digital typography.
+ They specifically target embedded systems and focus on bringing small, 
+ efficient and ubiquitous products.
 endef
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/freetype2 $(STAGING_DIR)/usr/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/ft2build.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir}/freetype2,,g' $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
+       mkdir -p $(2)/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(2)/bin/
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/freetype2 $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ft2build.h $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(1)/usr/lib/pkgconfig/
+       $(SED) 's,-I$$$$includedir/freetype2,-I$(STAGING_DIR)/usr/include/freetype2,g' $(2)/bin/freetype-config
+       $(SED) 's,/usr/include/freetype2/,$(STAGING_DIR)/usr/include/freetype2/,g' $(2)/bin/freetype-config
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/freetype-config \
-               $(STAGING_DIR)/usr/include/freetype2 \
-               $(STAGING_DIR)/usr/include/ft2build.h \
-               $(STAGING_DIR)/usr/lib/libfreetype.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
-endef
 
 define Package/libfreetype/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
 endef