ucmb: Fix compile on 2.6.36
[openwrt/svn-archive/archive.git] / libs / freetype / Makefile
index 1e400c55dd7bce8e0db1d02fa48d3ffe0b50c128..8a294ecc05ef583ede8c34e0ac278c67d096e0a6 100644 (file)
@@ -1,23 +1,24 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freetype
-PKG_VERSION:=2.3.7
-PKG_RELEASE:=1
+PKG_VERSION:=2.3.9
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/freetype
-PKG_MD5SUM:=83306194817ebdea554133b4232a34aa
+PKG_MD5SUM:=d76233108aca9c9606cdbd341562ad9a
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_LIBTOOL_PATHS:=builds/unix
 
+include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libfreetype
@@ -35,6 +36,8 @@ define Package/libfreetype/description
  efficient and ubiquitous products.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -44,30 +47,26 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(2)/bin
+       $(INSTALL_DIR) $(2)/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(2)/bin/
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/freetype2 $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/ft2build.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$$includedir/freetype2,-I$(STAGING_DIR)/usr/include/freetype2,g' $(2)/bin/freetype-config
-       $(SED) 's,/usr/include/freetype2/,$(STAGING_DIR)/usr/include/freetype2/,g' $(2)/bin/freetype-config
-endef
 
-define Build/UninstallDev
-       rm -rf $(1)/bin/freetype-config \
-               $(1)/usr/include/freetype2 \
-               $(1)/usr/include/ft2build.h \
-               $(1)/usr/lib/libfreetype.{a,so*} \
-               $(1)/usr/lib/pkgconfig/freetype2.pc
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1="$(STAGING_DIR)/usr",g' \
+                $(2)/bin/freetype-config
 endef
 
+
 define Package/libfreetype/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
 endef
 
+$(eval $(call HostBuild))
 $(eval $(call BuildPackage,libfreetype))