packages/freetype: update to 2.3.12
[openwrt/svn-archive/archive.git] / libs / freetype / Makefile
index c9f0339c675919f35c9071c7a5bea95e10f2f551..c4026c7ba312b0143c8e9eb00b2f147d86ccd702 100644 (file)
@@ -1,29 +1,32 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freetype
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freetype
-PKG_VERSION:=2.3.1
+PKG_VERSION:=2.3.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/freetype
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/freetype
-PKG_MD5SUM:=11e1186ca5520c5a284fa0a03f652035
+PKG_MD5SUM:=e974a82e5939be8e05ee65f07275d7c5
+
+PKG_FIXUP:=libtool
+PKG_LIBTOOL_PATHS:=builds/unix
 
 
+include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libfreetype
   SECTION:=libs
   CATEGORY:=Libraries
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libfreetype
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+zlib
   TITLE:=A free, high-quality and portable font engine
   URL:=http://www.freetype.org/
   TITLE:=A free, high-quality and portable font engine
   URL:=http://www.freetype.org/
+  DEPENDS:=+zlib
 endef
 
 define Package/libfreetype/description
 endef
 
 define Package/libfreetype/description
@@ -33,38 +36,37 @@ define Package/libfreetype/description
  efficient and ubiquitous products.
 endef
 
  efficient and ubiquitous products.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-define Build/Configure
-       $(call Build/Configure/Default)
-       $(call libtool_disable_rpath)
-endef
-
 define Build/Compile
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       mkdir -p $(2)/bin
+       $(INSTALL_DIR) $(2)/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(2)/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(2)/bin/
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/freetype2 $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/ft2build.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/freetype2 $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/ft2build.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(1)/usr/lib/pkgconfig/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$$includedir/freetype2,-I$(1)/usr/include/freetype2,g' $(2)/bin/freetype-config
-       $(SED) 's,/usr/include/freetype2/,$(1)/usr/include/freetype2/,g' $(2)/bin/freetype-config
+
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1="$(STAGING_DIR)/usr",g' \
+                $(2)/bin/freetype-config
 endef
 
 endef
 
+
 define Package/libfreetype/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
 endef
 
 define Package/libfreetype/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
 endef
 
+$(eval $(call HostBuild))
 $(eval $(call BuildPackage,libfreetype))
 $(eval $(call BuildPackage,libfreetype))