[package] rebuild libgd configure script before compiling (#6241)
[openwrt/svn-archive/archive.git] / libs / gd / Makefile
index 2649ee82d8f4e8e6c47878ea92a4a4ae5d3e36ca..175a3c71b852ecb13adacf057c100a62d280171f 100644 (file)
@@ -4,17 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gd
-PKG_VERSION:=2.0.33
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.35
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.boutell.com/gd/http
-PKG_MD5SUM:=be0a6d326cd8567e736fbc75df0a5c45
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.libgd.org/releases
+PKG_MD5SUM:=6c6c3dbb7bf079e0bb5fbbfd3bb8a71c
+
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,6 +27,11 @@ define Package/libgd
   URL:=http://www.boutell.com/gd/
 endef
 
+define Package/libgd/description
+  GD is an open source code library for the dynamic creation of images by
+  programmers. GD creates PNG, JPEG and GIF images, among other formats.
+endef
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -34,13 +40,19 @@ CONFIGURE_ARGS += \
        --without-freetype \
        --with-jpeg=$(STAGING_DIR)/usr \
        --with-png=$(STAGING_DIR)/usr \
-       --without-xpm
+       --without-xpm \
+       --without-iconv
 
 CONFIGURE_VARS += \
-       LIBPNG12_CONFIG="$(STAGING_DIR)/usr/bin/libpng12-config"
+       LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config"
 
 TARGET_CFLAGS += $(FPIC)
 
+define Build/Configure
+       ( cd $(PKG_BUILD_DIR); aclocal; libtoolize; autoreconf; );
+       $(call Build/Configure/Default)
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \