[packages] gd: remove manual autoreconf invocation, it pulls in host autofail crap
[openwrt/svn-archive/archive.git] / libs / gd / Makefile
index ed4c2d110a181d2b9b45b041844430eae816dd83..6c50cd508a6c4ea596611e9131f38bca6fa93204 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.libgd.org/releases
 PKG_MD5SUM:=6c6c3dbb7bf079e0bb5fbbfd3bb8a71c
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
+
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
@@ -48,12 +49,8 @@ CONFIGURE_ARGS += \
        --without-iconv
 
 CONFIGURE_VARS += \
-       LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config"
-
-define Build/Configure
-       ( cd $(PKG_BUILD_DIR); aclocal; libtoolize --force; autoreconf; );
-       $(call Build/Configure/Default)
-endef
+       LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config" \
+       ac_cv_header_iconv_h=no
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin