[packages] postgresql: add missing libpthread depends
[openwrt/svn-archive/archive.git] / libs / gd / Makefile
index ffe31ebfb9cda5c1279d4204c9659bfde63693dd..6c50cd508a6c4ea596611e9131f38bca6fa93204 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.libgd.org/releases
 PKG_MD5SUM:=6c6c3dbb7bf079e0bb5fbbfd3bb8a71c
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
+
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
@@ -34,6 +35,8 @@ define Package/libgd/description
   programmers. GD creates PNG, JPEG and GIF images, among other formats.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -46,25 +49,23 @@ CONFIGURE_ARGS += \
        --without-iconv
 
 CONFIGURE_VARS += \
-       LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config"
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Configure
-       ( cd $(PKG_BUILD_DIR); aclocal; libtoolize; autoreconf; );
-       $(call Build/Configure/Default)
-endef
+       LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config" \
+       ac_cv_header_iconv_h=no
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdlib-config $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gdlib-config $(1)/usr/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(1)/usr/bin/gdlib-config
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/entities.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gd{,_io,cache,fontg,fontl,fontmb,fonts,fontt,fx}.h \
                $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.{a,so*} $(1)/usr/lib/
-       $(SED) 's,-I$$$${prefix}/include,,g' $(1)/usr/bin/gdlib-config
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.{a,la,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(2)/bin
+       $(LN) ../../usr/bin/gdlib-config $(2)/bin/
 endef
 
 define Package/libgd/install