[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / libs / gd / Makefile
index 399f7c6e0c44a7c94dac2e27c411eea76e379d8c..77fbf0bf92455b22a20eaea670577a76b0c606f2 100644 (file)
@@ -4,17 +4,19 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gd
-PKG_VERSION:=2.0.33
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.35
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.boutell.com/gd/http
-PKG_MD5SUM:=be0a6d326cd8567e736fbc75df0a5c45
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.libgd.org/releases
+PKG_MD5SUM:=6c6c3dbb7bf079e0bb5fbbfd3bb8a71c
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,35 +28,40 @@ define Package/libgd
   URL:=http://www.boutell.com/gd/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-               --without-x \
-               --without-freetype \
-               --with-jpeg=$(STAGING_DIR)/usr \
-               --with-png=$(STAGING_DIR)/usr \
-               --without-xpm \
-               , \
-               LIBPNG12_CONFIG="$(STAGING_DIR)/usr/bin/libpng12-config" \
-       )
+define Package/libgd/description
+  GD is an open source code library for the dynamic creation of images by
+  programmers. GD creates PNG, JPEG and GIF images, among other formats.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --without-x \
+       --without-freetype \
+       --with-jpeg=$(STAGING_DIR)/usr \
+       --with-png=$(STAGING_DIR)/usr \
+       --without-xpm \
+       --without-iconv
+
+CONFIGURE_VARS += \
+       LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config"
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/Configure
+       ( cd $(PKG_BUILD_DIR); aclocal; libtoolize; autoreconf; );
+       $(call Build/Configure/Default)
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdlib-config $(1)/usr/bin/
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/entities.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gd{,_io,cache,fontg,fontl,fontmb,fonts,fontt,fx}.h \
                $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.{a,so*} $(1)/usr/lib/
        $(SED) 's,-I$$$${prefix}/include,,g' $(1)/usr/bin/gdlib-config
 endef