Fix wrong path to libpng12-config
[openwrt/svn-archive/archive.git] / libs / gd / Makefile
index cc8e85931157aae00cbeafcdb655230d21551deb..a7583ea8c353d0fd9536af01ad2add1000a45f4b 100644 (file)
@@ -9,15 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gd
-PKG_VERSION:=2.0.33
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.35
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.boutell.com/gd/http
-PKG_MD5SUM:=be0a6d326cd8567e736fbc75df0a5c45
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.libgd.org/releases
+PKG_MD5SUM:=6c6c3dbb7bf079e0bb5fbbfd3bb8a71c
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,21 +28,26 @@ define Package/libgd
   URL:=http://www.boutell.com/gd/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-               --without-x \
-               --without-freetype \
-               --with-jpeg=$(STAGING_DIR)/usr \
-               --with-png=$(STAGING_DIR)/usr \
-               --without-xpm \
-               , \
-               LIBPNG12_CONFIG="$(STAGING_DIR)/usr/bin/libpng12-config" \
-       )
+define Package/libgd/description
+  GD is an open source code library for the dynamic creation of images by
+  programmers. GD creates PNG, JPEG and GIF images, among other formats.
 endef
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --without-x \
+       --without-freetype \
+       --with-jpeg=$(STAGING_DIR)/usr \
+       --with-png=$(STAGING_DIR)/usr \
+       --without-xpm
+
+CONFIGURE_VARS += \
+       LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config"
+
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \