[packages] lftp: update to 4.1.1, use g++-uc, remove stdc++ hack, use tabs rather...
[openwrt/svn-archive/archive.git] / libs / gettext / Makefile
index a3c9479b42f006df2c41d2c040b83333d091446b..d43dc619f447245dad0fa228ab525641cc16c321 100644 (file)
@@ -1,64 +1,45 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext
-PKG_VERSION:=0.16.1
 PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=3d9ad24301c6d6b17ec30704a13fe127
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libintl
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=GNU Internationalization library
-  URL:=http://www.gnu.org/software/gettext/
+  TITLE:=Stub header for the GNU Internationalization library
 endef
 
-CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
-       --disable-rpath \
-       --enable-nls \
-       --disable-java \
-       --disable-native-java \
-       --disable-openmp \
-       --with-included-gettext \
-       --without-libintl-prefix \
-       --without-libexpat-prefix \
-       --without-emacs
+define Build/Prepare
+       $(INSTALL_DIR) $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef      
 
 define Build/Configure
-       $(call Build/Configure/Default)
-       $(call libtool_disable_rpath)
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
 endef
 
-define Build/InstallDev        
-       mkdir -p $(1)/usr/lib/libintl/include
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(1)/usr/lib/libintl/include/
-       mkdir -p $(1)/usr/lib/libintl/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libintl.{a,so*} $(1)/usr/lib/libintl/lib/
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/include/libintl.h $(1)/usr/include/
+
+       $(INSTALL_DIR) $(1)/usr/share/aclocal
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/m4/* $(1)/usr/share/aclocal/
 endef
 
 define Package/libintl/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libintl.so.* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/tmp
+       touch $(1)/tmp/.libintl-placeholder
 endef
 
 $(eval $(call BuildPackage,libintl))