[packages] libpar2: import Redhat/Gentoo par2cmdline-0.4-packed.patch - fixes repairi...
[openwrt/svn-archive/archive.git] / libs / glib2 / Makefile
index ca49bd8a9b44fe154ce754c3aa7d368ad326e2cc..da44539016c793ab053bbd8b81a2329c1c3eafe7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,28 +8,29 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glib2
-PKG_VERSION:=2.20.0
-PKG_RELEASE:=1
+PKG_VERSION:=2.26.1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=glib-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
-PKG_SOURCE_URL:=@GNOME/glib/2.20
-PKG_MD5SUM:=05188e560dbd8bddd568e24ce10dd003
+PKG_SOURCE_URL:=@GNOME/glib/2.26
+PKG_MD5SUM:=17535accceef55bcb17a74d73f9c2aef
 
-PKG_FIXUP = libtool
-PKG_BUILD_DEPENDS := glib2/host
+PKG_FIXUP:=autoreconf
+PKG_BUILD_DEPENDS:=glib2/host libpthread zlib
+HOST_BUILD_DEPENDS:=gettext/host libiconv/host
+PKG_INSTALL:=1
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/glib-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
-
-PKG_INSTALL:=1
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/glib2
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libiconv +libintl
+  DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS)
   TITLE:=glib 2.0
   URL:=http://www.gtk.org/
 endef
@@ -38,26 +39,21 @@ define Package/glib2/description
   The GLib library of C routines
 endef
 
-TARGET_CFLAGS+= \
-       $(FPIC) \
-       -I$(STAGING_DIR)/usr/lib/libiconv/include \
-       -I$(STAGING_DIR)/usr/lib/libintl/include
-
-TARGET_LDFLAGS+= \
-       -L$(STAGING_DIR)/usr/lib/libiconv/lib \
-       -L$(STAGING_DIR)/usr/lib/libintl/lib
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
                --enable-debug=no \
-               --with-libiconv=gnu \
+               --disable-selinux \
+        --disable-fam \
+        $(if $(ICONV_FULL),--with-libiconv=gnu) \
                , \
                glib_cv_stack_grows=no \
                glib_cv_uscore=no \
                ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR_HOST)/bin/glib-genmarshal \
                ac_cv_func_mmap_fixed_mapped=yes \
+               ac_cv_func_posix_getpwuid_r=yes \
+               ac_cv_func_posix_getgrgid_r=yes \
        );
 endef
 
@@ -66,6 +62,9 @@ define Build/InstallDev
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/glib-2.0 \
                $(1)/usr/include/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/glib-2.0/include/*.h \
+               $(1)/usr/include/glib-2.0/
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/gio-unix-2.0 \
                $(1)/usr/include/