[8.09] [packages] gnutls: fix 2 vulnerabilities allowing Man-in-the-Middle attacks
[openwrt/svn-archive/archive.git] / libs / gnutls / Makefile
index ea68dfc5d8011e1720dac0d755991b9aabecac88..0f747b647e3006f6aa485c78e291441b86e0b038 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2005-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
-PKG_VERSION:=2.0.0
-PKG_RELEASE:=1
+PKG_VERSION:=2.4.1
+PKG_RELEASE:=2.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://josefsson.org/gnutls/releases/ \
-       http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
+PKG_SOURCE_URL:=http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
        ftp://ftp.gnutls.org/pub/gnutls/ \
-       ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/ \
-       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/
-PKG_MD5SUM:=181b2ff554a83e6cf85505ea16699d39
+       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
+       http://josefsson.org/gnutls/releases/
+PKG_MD5SUM:=573db36cb3f8472b0293cfa1f52c607a
+
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -61,15 +62,15 @@ endef
 
 define Package/gnutls-utils/description
 $(call Package/gnutls/Default/description)
- This package contains the GnuTLS gnutls-cli, gnutls-serv and psktool
- utilities.
+ This package contains the GnuTLS gnutls-cli, gnutls-serv, psktool,
and srptool utilities.
 endef
 
 
 define Package/libgnutls
 $(call Package/gnutls/Default)
  TITLE+= (library)
- DEPENDS+= +libgcrypt +libgpg-error
+ DEPENDS+= +zlib +libgcrypt +libgpg-error
 endef
 
 define Package/libgnutls/description
@@ -101,36 +102,17 @@ $(call Package/gnutls/Default/description)
  This package contains the GnuTLS OpenSSL compatibility layer shared library.
 endef
 
-
-# XXX: configure will disable any of theese if they're present regardless of
-# the "--enable" prefix
-#      --enable-anon-authentication \
-#      --enable-openpgp-authentication \
-#      --enable-psk-authentication \
-#      --enable-srp-authentication \
-#      --enable-tls-authorization \
-#
-# and the following prevents the library from building so it's ommited
-#      --disable-tls-authorization
+TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
-       --disable-anon-authentication \
        --disable-openpgp-authentication \
-       --disable-psk-authentication \
-       --disable-srp-authentication \
-       --with-included-libtasn1 \
        --with-included-libcfg \
-       --without-included-opencdk \
-       --with-libgcrypt \
+       --with-included-libtasn1 \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
-       --without-libiconv-prefix \
-       --without-libintl-prefix \
-       --without-libopencdk-prefix \
        --with-libreadline-prefix="$(STAGING_DIR)/usr" \
-       --without-lzo \
-       --without-zlib \
+       --with-libz-prefix="$(STAGING_DIR)/usr" \
 
 # XXX: AM_CFLAGS duplicates with CFLAGS
 MAKE_ARGS:= \
@@ -140,34 +122,20 @@ define Build/Configure
        $(SED) 's,-I$$$${includedir},,g' $(PKG_BUILD_DIR)/configure
        $(SED) 's,-L$$$${libdir},,g' $(PKG_BUILD_DIR)/configure
        $(call Build/Configure/Default)
-       $(call libtool_disable_rpath)
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_ARGS) all
-       $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_ARGS) DESTDIR="$(PKG_INSTALL_DIR)" install
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
+       $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_ARGS) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
+       mkdir -p $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(2)/bin/
-       mkdir -p $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gnutls $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/UninstallDev
-       rm -rf $(2)/usr/bin/libgnutls{,-extra}-config \
-               $(1)/usr/include/gnutls \
-               $(1)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} \
-               $(1)/usr/lib/pkgconfig/gnutls{,-extra}.pc
-endef
-
-
 define Package/certtool/conffiles
 /etc/gnutls/certtool.cfg
 endef
@@ -184,6 +152,7 @@ define Package/gnutls-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/psktool $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/srptool $(1)/usr/bin/
 endef