[package] update xmlrpc-c to 1.22.2 (#7250)
[openwrt/svn-archive/archive.git] / libs / gnutls / Makefile
index a096542289c429d08f00c57fe454aca4b2ef7324..1316842b1372aa26bebc0399d2cb7b5f8b0ee27a 100644 (file)
@@ -1,30 +1,29 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2005-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
-PKG_VERSION:=2.0.0
+PKG_VERSION:=2.8.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://josefsson.org/gnutls/releases/ \
-       http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
-       ftp://ftp.gnutls.org/pub/gnutls/ \
-       ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/ \
+PKG_SOURCE_URL:=@GNU/gnutls \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/
-PKG_MD5SUM:=181b2ff554a83e6cf85505ea16699d39
+PKG_MD5SUM:=eb0a6d7d3cb9ac684d971c14f9f6d3ba
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+PKG_LIBTOOL_PATHS:=. lib libextra
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gnutls/Default
+  SUBMENU:=SSL
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=GNU TLS
@@ -34,8 +33,7 @@ endef
 define Package/gnutls/Default/description
  GnuTLS is a project that aims to develop a library which provides a
  secure layer, over a reliable transport layer. Currently the GnuTLS
- library implements the proposed standards by the IETF's TLS working
- group.
+ library implements the SSL 3.0, TLS 1.0, and TLS 1.1 protocols.
 endef
 
 
@@ -63,15 +61,15 @@ endef
 
 define Package/gnutls-utils/description
 $(call Package/gnutls/Default/description)
- This package contains the GnuTLS gnutls-cli, gnutls-serv and psktool
- utilities.
+ This package contains the GnuTLS gnutls-cli, gnutls-serv, psktool,
and srptool utilities.
 endef
 
 
 define Package/libgnutls
 $(call Package/gnutls/Default)
- TITLE+= (library)
DEPENDS+= +libgcrypt +libgpg-error
 TITLE+= (library)
 DEPENDS+= +zlib +libgcrypt +libgpg-error
 endef
 
 define Package/libgnutls/description
@@ -82,8 +80,8 @@ endef
 
 define Package/libgnutls-extra
 $(call Package/gnutls/Default)
- TITLE+= (extra library)
- DEPENDS+= +libgnutls
 TITLE+= (extra library)
 DEPENDS+= +libgnutls
 endef
 
 define Package/libgnutls-extra/description
@@ -94,8 +92,8 @@ endef
 
 define Package/libgnutls-openssl
 $(call Package/gnutls/Default)
- TITLE+= (OpenSSL compat library)
- DEPENDS+= +libgnutls
 TITLE+= (OpenSSL compat library)
 DEPENDS+= +libgnutls
 endef
 
 define Package/libgnutls-openssl/description
@@ -103,57 +101,41 @@ $(call Package/gnutls/Default/description)
  This package contains the GnuTLS OpenSSL compatibility layer shared library.
 endef
 
-
-# XXX: configure will disable any of theese if they're present regardless of
-# the "--enable" prefix
-#      --enable-anon-authentication \
-#      --enable-openpgp-authentication \
-#      --enable-psk-authentication \
-#      --enable-srp-authentication \
-#      --enable-tls-authorization \
-#
-# and the following prevents the library from building so it's ommited
-#      --disable-tls-authorization
-
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
-       --disable-anon-authentication \
        --disable-openpgp-authentication \
-       --disable-psk-authentication \
-       --disable-srp-authentication \
-       --with-included-libtasn1 \
+       --disable-guile \
        --with-included-libcfg \
-       --without-included-opencdk \
-       --with-libgcrypt \
+       --with-included-libtasn1 \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
-       --without-libiconv-prefix \
-       --without-libintl-prefix \
-       --without-libopencdk-prefix \
        --with-libreadline-prefix="$(STAGING_DIR)/usr" \
+       --with-libz-prefix="$(STAGING_DIR)/usr" \
        --without-lzo \
-       --without-zlib \
 
 # XXX: AM_CFLAGS duplicates with CFLAGS
-MAKE_ARGS:= \
+MAKE_FLAGS:= \
        AM_CFLAGS="" \
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Configure
        $(SED) 's,-I$$$${includedir},,g' $(PKG_BUILD_DIR)/configure
        $(SED) 's,-L$$$${libdir},,g' $(PKG_BUILD_DIR)/configure
        $(call Build/Configure/Default)
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_ARGS) DESTDIR="$(PKG_INSTALL_DIR)" all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(2)/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/gnutls $(1)/usr/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib/pkgconfig
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/gnutls \
+               $(1)/usr/include/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} \
+               $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc \
+               $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/certtool/conffiles
@@ -164,14 +146,17 @@ define Package/certtool/install
        $(INSTALL_DIR) $(1)/etc/gnutls
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/doc/certtool.cfg $(1)/etc/gnutls/
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/certtool $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/certtool $(1)/usr/bin/
 endef
 
 
 define Package/gnutls-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/psktool $(1)/usr/bin/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} \
+               $(PKG_INSTALL_DIR)/usr/bin/psktool \
+               $(PKG_INSTALL_DIR)/usr/bin/srptool \
+               $(1)/usr/bin/
 endef