gnutls tweaks:
[openwrt/svn-archive/archive.git] / libs / gnutls / Makefile
index 6ae891be860d4bb8badf91761e32a32693a155e5..42ee26f8b978f9c7df5f65a5f1357d2e1c8b350d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2005-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,20 +9,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
-PKG_VERSION:=1.0.25
-PKG_RELEASE:=0
+PKG_VERSION:=2.4.1
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/ \
-       ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/ \
-       http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
+       ftp://ftp.gnutls.org/pub/gnutls/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
        http://josefsson.org/gnutls/releases/
-PKG_MD5SUM:=3585b5b204135e51e0efc9084b3e028b
-PKG_CAT:=zcat
+PKG_MD5SUM:=573db36cb3f8472b0293cfa1f52c607a
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,111 +27,153 @@ define Package/gnutls/Default
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=GNU TLS
-  DESCRIPTION:=\
-       GnuTLS is a project that aims to develop a library which provides a \\\
-       secure layer, over a reliable transport layer. Currently the GnuTLS \\\
-       library implements the proposed standards by the IETF's TLS working \\\
-       group.
   URL:=http://www.gnu.org/software/gnutls/
 endef
 
+define Package/gnutls/Default/description
+ GnuTLS is a project that aims to develop a library which provides a
+ secure layer, over a reliable transport layer. Currently the GnuTLS
+ library implements the proposed standards by the IETF's TLS working
+ group.
+endef
+
+
+define Package/certtool
+$(call Package/gnutls/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE+= (certool utility)
+  DEPENDS+= +libgnutls +libncurses +libreadline
+endef
+
+define Package/certtool/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS certtool utility.
+endef
+
+
 define Package/gnutls-utils
-  $(call Package/gnutls/Default)
+$(call Package/gnutls/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libgnutls
   TITLE+= (utilities)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains some GnuTLS utilities.
+  DEPENDS+= +libgnutls +libgnutls-extra
+endef
+
+define Package/gnutls-utils/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS gnutls-cli, gnutls-serv, psktool,
+ and srptool utilities.
 endef
 
+
 define Package/libgnutls
-  $(call Package/gnutls/Default)
-  DEPENDS:=+libgcrypt
-  TITLE+= (library)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the GnuTLS shared libraries, needed by other programs.
+$(call Package/gnutls/Default)
+ TITLE+= (library)
+ DEPENDS+= +zlib +libgcrypt +libgpg-error
+endef
+
+define Package/libgnutls/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS shared library, needed by other programs.
+endef
+
+
+define Package/libgnutls-extra
+$(call Package/gnutls/Default)
+ TITLE+= (extra library)
+ DEPENDS+= +libgnutls
 endef
 
+define Package/libgnutls-extra/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS extra shared library.
+endef
+
+
 define Package/libgnutls-openssl
-  $(call Package/gnutls/Default)
-  DEPENDS:=libgnutls
-  TITLE+= (OpenSSL compat library)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the GnuTLS OpenSSL compatibility layer shared library.
+$(call Package/gnutls/Default)
+ TITLE+= (OpenSSL compat library)
+ DEPENDS+= +libgnutls
+endef
+
+define Package/libgnutls-openssl/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS OpenSSL compatibility layer shared library.
 endef
 
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --disable-openpgp-authentication \
+       --with-included-libcfg \
+       --with-included-libtasn1 \
+       --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
+       --with-libreadline-prefix="$(STAGING_DIR)/usr" \
+       --with-libz-prefix="$(STAGING_DIR)/usr" \
+
+# XXX: AM_CFLAGS duplicates with CFLAGS
+MAKE_ARGS:= \
+       AM_CFLAGS="" \
+
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch \
-               configure.in \
-               acinclude.m4 \
-               aclocal.m4 \
-               Makefile.in \
-               config.h.in \
-               configure \
-       )
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-srp-authentication \
-               --disable-anon-authentication \
-               --disable-openpgp-authentication \
-               --with-included-opencdk=yes \
-               --with-included-libtasn1=yes \
-               --with-included-libcfg=yes \
-               --without-zlib \
-               --without-lzo \
-       )
+       $(SED) 's,-I$$$${includedir},,g' $(PKG_BUILD_DIR)/configure
+       $(SED) 's,-L$$$${libdir},,g' $(PKG_BUILD_DIR)/configure
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_ARGS) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/gnutls $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc
-       mkdir -p $(STAGING_DIR)/usr/share/aclocal
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgnutls{,-extra}.m4 $(STAGING_DIR)/usr/share/aclocal/
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/bin/libgnutls{,-extra}-config \
-               $(STAGING_DIR)/usr/include/gnutls \
-               $(STAGING_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc \
-               $(STAGING_DIR)/usr/share/aclocal/libgnutls{,-extra}.m4
+       mkdir -p $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(2)/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/gnutls $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/certtool/conffiles
+/etc/gnutls/certtool.cfg
 endef
 
+define Package/certtool/install
+       $(INSTALL_DIR) $(1)/etc/gnutls
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/doc/certtool.cfg $(1)/etc/gnutls/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/certtool $(1)/usr/bin/
+endef
+
+
 define Package/gnutls-utils/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/certtool $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/psktool $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/srptool $(1)/usr/bin/
 endef
 
+
 define Package/libgnutls/install
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra}.so.* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls.so.* $(1)/usr/lib/
 endef
 
+
+define Package/libgnutls-extra/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-extra.so.* $(1)/usr/lib/
+endef
+
+
 define Package/libgnutls-openssl/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-openssl.so.* $(1)/usr/lib/
 endef
 
+
+$(eval $(call BuildPackage,certtool))
 $(eval $(call BuildPackage,gnutls-utils))
 $(eval $(call BuildPackage,libgnutls))
+$(eval $(call BuildPackage,libgnutls-extra))
 $(eval $(call BuildPackage,libgnutls-openssl))