lots of package cleanups/fixes
[openwrt/svn-archive/archive.git] / libs / gnutls / Makefile
index bb0f960e96254f8774f0607261189b5cdb47b54a..a096542289c429d08f00c57fe454aca4b2ef7324 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
-PKG_VERSION:=1.0.25
-PKG_RELEASE:=0
+PKG_VERSION:=2.0.0
+PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/ \
-       ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/ \
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://josefsson.org/gnutls/releases/ \
        http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
-       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
-       http://josefsson.org/gnutls/releases/
-PKG_MD5SUM:=3585b5b204135e51e0efc9084b3e028b
-PKG_CAT:=zcat
+       ftp://ftp.gnutls.org/pub/gnutls/ \
+       ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/ \
+       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/
+PKG_MD5SUM:=181b2ff554a83e6cf85505ea16699d39
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/libgnutls
+define Package/gnutls/Default
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libgcrypt
-  TITLE:=GNU TLS library
-  DESCRIPTION:=The GNU TLS library.\\\
-    GnuTLS is a project that aims to develop a library which provides a \\\
-    secure layer, over a reliable transport layer. Currently the GnuTLS \\\
-    library implements the proposed standards by the IETF's TLS working \\\
-    group.\\\
-    \\\
-    This packages contains the GnuTLS shared libraries, needed by other programs.
+  TITLE:=GNU TLS
   URL:=http://www.gnu.org/software/gnutls/
 endef
 
-define Package/libgnutls-openssl
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libgnutls
-  TITLE:=GNU TLS OpenSSL compatibility layer library
-  DESCRIPTION:=The GNU TLS OpenSSL compatibility layer library.\\\
-    GnuTLS is a project that aims to develop a library which provides a \\\
-    secure layer, over a reliable transport layer. Currently the GnuTLS \\\
-    library implements the proposed standards by the IETF's TLS working \\\
-    group.\\\
-    \\\
-    This packages contains the GnuTLS OpenSSL compatibility layer shared library.
-  URL:=http://www.gnu.org/software/gnutls/
+define Package/gnutls/Default/description
+ GnuTLS is a project that aims to develop a library which provides a
+ secure layer, over a reliable transport layer. Currently the GnuTLS
+ library implements the proposed standards by the IETF's TLS working
+ group.
 endef
 
+
+define Package/certtool
+$(call Package/gnutls/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE+= (certool utility)
+  DEPENDS+= +libgnutls +libncurses +libreadline
+endef
+
+define Package/certtool/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS certtool utility.
+endef
+
+
 define Package/gnutls-utils
+$(call Package/gnutls/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libgnutls
-  TITLE:=GNU TLS utilitis
-  DESCRIPTION:=The GNU TLS utilities.\\\
-    GnuTLS is a project that aims to develop a library which provides a \\\
-    secure layer, over a reliable transport layer. Currently the GnuTLS \\\
-    library implements the proposed standards by the IETF's TLS working \\\
-    group.\\\
-    \\\
-    This packages contains some GnuTLS utilities.
-  URL:=http://www.gnu.org/software/gnutls/
+  TITLE+= (utilities)
+  DEPENDS+= +libgnutls +libgnutls-extra
+endef
+
+define Package/gnutls-utils/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS gnutls-cli, gnutls-serv and psktool
+ utilities.
+endef
+
+
+define Package/libgnutls
+$(call Package/gnutls/Default)
+ TITLE+= (library)
+ DEPENDS+= +libgcrypt +libgpg-error
 endef
 
+define Package/libgnutls/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS shared library, needed by other programs.
+endef
+
+
+define Package/libgnutls-extra
+$(call Package/gnutls/Default)
+ TITLE+= (extra library)
+ DEPENDS+= +libgnutls
+endef
+
+define Package/libgnutls-extra/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS extra shared library.
+endef
+
+
+define Package/libgnutls-openssl
+$(call Package/gnutls/Default)
+ TITLE+= (OpenSSL compat library)
+ DEPENDS+= +libgnutls
+endef
+
+define Package/libgnutls-openssl/description
+$(call Package/gnutls/Default/description)
+ This package contains the GnuTLS OpenSSL compatibility layer shared library.
+endef
+
+
+# XXX: configure will disable any of theese if they're present regardless of
+# the "--enable" prefix
+#      --enable-anon-authentication \
+#      --enable-openpgp-authentication \
+#      --enable-psk-authentication \
+#      --enable-srp-authentication \
+#      --enable-tls-authorization \
+#
+# and the following prevents the library from building so it's ommited
+#      --disable-tls-authorization
+
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --disable-anon-authentication \
+       --disable-openpgp-authentication \
+       --disable-psk-authentication \
+       --disable-srp-authentication \
+       --with-included-libtasn1 \
+       --with-included-libcfg \
+       --without-included-opencdk \
+       --with-libgcrypt \
+       --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
+       --without-libiconv-prefix \
+       --without-libintl-prefix \
+       --without-libopencdk-prefix \
+       --with-libreadline-prefix="$(STAGING_DIR)/usr" \
+       --without-lzo \
+       --without-zlib \
+
+# XXX: AM_CFLAGS duplicates with CFLAGS
+MAKE_ARGS:= \
+       AM_CFLAGS="" \
+
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               touch configure.in ; \
-               touch acinclude.m4 ; \
-               touch aclocal.m4 ; \
-               touch Makefile.in ; \
-               touch config.h.in ; \
-               touch configure ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --disable-srp-authentication \
-                       --disable-anon-authentication \
-                       --disable-openpgp-authentication \
-                       --with-included-opencdk=yes \
-                       --with-included-libtasn1=yes \
-                       --with-included-libcfg=yes \
-                       --without-zlib \
-                       --without-lzo \
-       );
+       $(SED) 's,-I$$$${includedir},,g' $(PKG_BUILD_DIR)/configure
+       $(SED) 's,-L$$$${libdir},,g' $(PKG_BUILD_DIR)/configure
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_ARGS) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
-define Package/libgnutls/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra}.so.* $(1)/usr/lib/
+define Build/InstallDev
+       mkdir -p $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(2)/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/gnutls $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Package/libgnutls-openssl/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-openssl.so.* $(1)/usr/lib/
+define Package/certtool/conffiles
+/etc/gnutls/certtool.cfg
 endef
 
+define Package/certtool/install
+       $(INSTALL_DIR) $(1)/etc/gnutls
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/doc/certtool.cfg $(1)/etc/gnutls/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/certtool $(1)/usr/bin/
+endef
+
+
 define Package/gnutls-utils/install
-       install -m0755 -d $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/certtool $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/psktool $(1)/usr/bin/
 endef
 
-define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/gnutls $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       mkdir -p $(STAGING_DIR)/usr/share/aclocal
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgnutls{,-extra}.m4 $(STAGING_DIR)/usr/share/aclocal/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/libgnutls{,-extra}-config \
-               $(STAGING_DIR)/usr/include/gnutls \
-               $(STAGING_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc \
-               $(STAGING_DIR)/usr/share/aclocal/libgnutls{,-extra}.m4
+
+define Package/libgnutls/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls.so.* $(1)/usr/lib/
+endef
+
+
+define Package/libgnutls-extra/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-extra.so.* $(1)/usr/lib/
+endef
+
+
+define Package/libgnutls-openssl/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-openssl.so.* $(1)/usr/lib/
 endef
 
+
+$(eval $(call BuildPackage,certtool))
+$(eval $(call BuildPackage,gnutls-utils))
 $(eval $(call BuildPackage,libgnutls))
+$(eval $(call BuildPackage,libgnutls-extra))
 $(eval $(call BuildPackage,libgnutls-openssl))
-$(eval $(call BuildPackage,gnutls-utils))