Fix libtool pkg-config paths #1716
[openwrt/svn-archive/archive.git] / libs / gnutls / Makefile
index 3185043d6e19eddb14789f818c0f4cb25f6fe39f..a7f595df59021c29e031c0b3245ec30447dd4525 100644 (file)
@@ -12,7 +12,6 @@ PKG_NAME:=gnutls
 PKG_VERSION:=1.0.25
 PKG_RELEASE:=0
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/ \
        ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/ \
@@ -22,125 +21,81 @@ PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/ \
 PKG_MD5SUM:=3585b5b204135e51e0efc9084b3e028b
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/libgnutls
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=+libgcrypt
-  TITLE:=GNU TLS library
-  DESCRIPTION:=The GNU TLS library.\\\
-    GnuTLS is a project that aims to develop a library which provides a \\\
-    secure layer, over a reliable transport layer. Currently the GnuTLS \\\
-    library implements the proposed standards by the IETF's TLS working \\\
-    group.\\\
-    \\\
-    This packages contains the GnuTLS shared libraries, needed by other programs.
-  URL:=http://www.gnu.org/software/gnutls/
-endef
-
-define Package/libgnutls-openssl
+define Package/gnutls/Default
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=libgnutls
-  TITLE:=GNU TLS OpenSSL compatibility layer library
-  DESCRIPTION:=The GNU TLS OpenSSL compatibility layer library.\\\
-    GnuTLS is a project that aims to develop a library which provides a \\\
-    secure layer, over a reliable transport layer. Currently the GnuTLS \\\
-    library implements the proposed standards by the IETF's TLS working \\\
-    group.\\\
-    \\\
-    This packages contains the GnuTLS OpenSSL compatibility layer shared library.
+  TITLE:=GNU TLS
+  DESCRIPTION:=\
+       GnuTLS is a project that aims to develop a library which provides a \\\
+       secure layer, over a reliable transport layer. Currently the GnuTLS \\\
+       library implements the proposed standards by the IETF's TLS working \\\
+       group.
   URL:=http://www.gnu.org/software/gnutls/
 endef
 
 define Package/gnutls-utils
+  $(call Package/gnutls/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+libgnutls
-  TITLE:=GNU TLS utilitis
-  DESCRIPTION:=The GNU TLS utilities.\\\
-    GnuTLS is a project that aims to develop a library which provides a \\\
-    secure layer, over a reliable transport layer. Currently the GnuTLS \\\
-    library implements the proposed standards by the IETF's TLS working \\\
-    group.\\\
-    \\\
-    This packages contains some GnuTLS utilities.
-  URL:=http://www.gnu.org/software/gnutls/
+  TITLE+= (utilities)
+  DESCRIPTION+=\\\
+       \\\
+       This package contains some GnuTLS utilities.
+endef
+
+define Package/libgnutls
+  $(call Package/gnutls/Default)
+  DEPENDS:=+libgcrypt
+  TITLE+= (library)
+  DESCRIPTION+=\\\
+       \\\
+       This package contains the GnuTLS shared libraries, needed by other programs.
+endef
+
+define Package/libgnutls-openssl
+  $(call Package/gnutls/Default)
+  DEPENDS:=libgnutls
+  TITLE+= (OpenSSL compat library)
+  DESCRIPTION+=\\\
+       \\\
+       This package contains the GnuTLS OpenSSL compatibility layer shared library.
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               touch configure.in ; \
-               touch acinclude.m4 ; \
-               touch aclocal.m4 ; \
-               touch Makefile.in ; \
-               touch config.h.in ; \
-               touch configure ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --disable-srp-authentication \
-                       --disable-anon-authentication \
-                       --disable-openpgp-authentication \
-                       --with-included-opencdk=yes \
-                       --with-included-libtasn1=yes \
-                       --with-included-libcfg=yes \
-                       --without-zlib \
-                       --without-lzo \
-       );
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               acinclude.m4 \
+               aclocal.m4 \
+               Makefile.in \
+               config.h.in \
+               configure \
+       )
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --disable-srp-authentication \
+               --disable-anon-authentication \
+               --disable-openpgp-authentication \
+               --with-included-opencdk=yes \
+               --with-included-libtasn1=yes \
+               --with-included-libcfg=yes \
+               --without-zlib \
+               --without-lzo \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libgnutls/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra}.so.* $(1)/usr/lib/
-endef
-
-define Package/libgnutls-openssl/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-openssl.so.* $(1)/usr/lib/
-endef
-
-define Package/gnutls-utils/install
-       install -m0755 -d $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/certtool $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(STAGING_DIR)/usr/bin/
@@ -154,17 +109,34 @@ define Build/InstallDev
        $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc
        mkdir -p $(STAGING_DIR)/usr/share/aclocal
        $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgnutls{,-extra}.m4 $(STAGING_DIR)/usr/share/aclocal/
+       $(SED)  "s,"prefix\=/usr",prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/gnutls-extra.pc
+       $(SED)  "s,"exec_prefix\=/usr",exec_prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/gnutls-extra.pc
 endef
 
 define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/libgnutls{,-extra}-config \
+       rm -rf  $(STAGING_DIR)/usr/bin/libgnutls{,-extra}-config \
                $(STAGING_DIR)/usr/include/gnutls \
                $(STAGING_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} \
                $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc \
                $(STAGING_DIR)/usr/share/aclocal/libgnutls{,-extra}.m4
 endef
 
+define Package/gnutls-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/certtool $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
+endef
+
+define Package/libgnutls/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra}.so.* $(1)/usr/lib/
+endef
+
+define Package/libgnutls-openssl/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-openssl.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,gnutls-utils))
 $(eval $(call BuildPackage,libgnutls))
 $(eval $(call BuildPackage,libgnutls-openssl))
-$(eval $(call BuildPackage,gnutls-utils))