[packages] massive: use $(INSTALL_DIR) instead of 'mkdir -p' in install and InstallDev
[openwrt/svn-archive/archive.git] / libs / gnutls / Makefile
index 0937a82f7d76b844853e825a28d58c44b284b417..e2c0af9eceea3ca76ae81c698754e8875eeedf53 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2005-2008 OpenWrt.org
+# Copyright (C) 2005-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
-PKG_VERSION:=2.4.1
-PKG_RELEASE:=2
+PKG_VERSION:=2.8.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.gnu.org/pub/gnu/gnutls/ \
-       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
-       http://josefsson.org/gnutls/releases/
-PKG_MD5SUM:=573db36cb3f8472b0293cfa1f52c607a
+PKG_SOURCE_URL:=@GNU/gnutls \
+       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/
+PKG_MD5SUM:=
 
 PKG_FIXUP = libtool
 
@@ -31,8 +30,7 @@ endef
 define Package/gnutls/Default/description
  GnuTLS is a project that aims to develop a library which provides a
  secure layer, over a reliable transport layer. Currently the GnuTLS
- library implements the proposed standards by the IETF's TLS working
- group.
+ library implements the SSL 3.0, TLS 1.0, and TLS 1.1 protocols.
 endef
 
 
@@ -69,6 +67,7 @@ define Package/libgnutls
 $(call Package/gnutls/Default)
  TITLE+= (library)
  DEPENDS+= +zlib +libgcrypt +libgpg-error
+ SUBMENU:=SSL
 endef
 
 define Package/libgnutls/description
@@ -81,6 +80,7 @@ define Package/libgnutls-extra
 $(call Package/gnutls/Default)
  TITLE+= (extra library)
  DEPENDS+= +libgnutls
+ SUBMENU:=SSL
 endef
 
 define Package/libgnutls-extra/description
@@ -93,6 +93,7 @@ define Package/libgnutls-openssl
 $(call Package/gnutls/Default)
  TITLE+= (OpenSSL compat library)
  DEPENDS+= +libgnutls
+ SUBMENU:=SSL
 endef
 
 define Package/libgnutls-openssl/description
@@ -106,6 +107,7 @@ CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
        --disable-openpgp-authentication \
+       --disable-guile \
        --with-included-libcfg \
        --with-included-libtasn1 \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
@@ -127,8 +129,7 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(2)/bin/
+       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gnutls $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(1)/usr/lib/pkgconfig/