[packages] massive: use $(INSTALL_DIR) instead of 'mkdir -p' in install and InstallDev
[openwrt/svn-archive/archive.git] / libs / gnutls / Makefile
index f7cb18feac493a001ddff269ecc341456aa1f090..e2c0af9eceea3ca76ae81c698754e8875eeedf53 100644 (file)
@@ -1,23 +1,20 @@
 #
-# Copyright (C) 2005-2008 OpenWrt.org
+# Copyright (C) 2005-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
-PKG_VERSION:=2.4.1
+PKG_VERSION:=2.8.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
-       ftp://ftp.gnutls.org/pub/gnutls/ \
-       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
-       http://josefsson.org/gnutls/releases/
-PKG_MD5SUM:=573db36cb3f8472b0293cfa1f52c607a
+PKG_SOURCE_URL:=@GNU/gnutls \
+       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/
+PKG_MD5SUM:=
 
 PKG_FIXUP = libtool
 
@@ -33,8 +30,7 @@ endef
 define Package/gnutls/Default/description
  GnuTLS is a project that aims to develop a library which provides a
  secure layer, over a reliable transport layer. Currently the GnuTLS
- library implements the proposed standards by the IETF's TLS working
- group.
+ library implements the SSL 3.0, TLS 1.0, and TLS 1.1 protocols.
 endef
 
 
@@ -70,7 +66,8 @@ endef
 define Package/libgnutls
 $(call Package/gnutls/Default)
  TITLE+= (library)
- DEPENDS+= +zlib +libtasn1 +libgcrypt +libgpg-error
+ DEPENDS+= +zlib +libgcrypt +libgpg-error
+ SUBMENU:=SSL
 endef
 
 define Package/libgnutls/description
@@ -83,6 +80,7 @@ define Package/libgnutls-extra
 $(call Package/gnutls/Default)
  TITLE+= (extra library)
  DEPENDS+= +libgnutls
+ SUBMENU:=SSL
 endef
 
 define Package/libgnutls-extra/description
@@ -95,6 +93,7 @@ define Package/libgnutls-openssl
 $(call Package/gnutls/Default)
  TITLE+= (OpenSSL compat library)
  DEPENDS+= +libgnutls
+ SUBMENU:=SSL
 endef
 
 define Package/libgnutls-openssl/description
@@ -102,14 +101,18 @@ $(call Package/gnutls/Default/description)
  This package contains the GnuTLS OpenSSL compatibility layer shared library.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
        --disable-openpgp-authentication \
+       --disable-guile \
+       --with-included-libcfg \
+       --with-included-libtasn1 \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
        --with-libreadline-prefix="$(STAGING_DIR)/usr" \
        --with-libz-prefix="$(STAGING_DIR)/usr" \
-       --with-libtasn1-prefix="$(STAGING_DIR)/usr"
 
 # XXX: AM_CFLAGS duplicates with CFLAGS
 MAKE_ARGS:= \
@@ -126,8 +129,7 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(2)/bin/
+       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gnutls $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(1)/usr/lib/pkgconfig/