remove UninstallDev
[openwrt/svn-archive/archive.git] / libs / gsm / Makefile
index 0e18cadf162a8230f7b34b61cebe383dd42752fb..12ffa72a324a5f34c8a610fa866fa0a3d0933552 100644 (file)
@@ -16,7 +16,6 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.0-pl10
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.cs.tu-berlin.de/pub/local/kbs/tubmik/gsm/
 PKG_MD5SUM:=4b148480f82e96d274248e13880ec873
-PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
@@ -26,27 +25,33 @@ define Package/libgsm
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=A GSM transcoding library
-  DESCRIPTION:=A GSM 06.10 full-rate speech transcoding implementation (library).\\\
-    An implementation of the European GSM 06.10 provisional standard \\\
-    for full-rate speech transcoding, prI-ETS 300 036, which uses \\\
-    RPE/LTP (residual pulse excitation/long term prediction) coding \\\
-    at 13 kbit/s.
   URL:=ftp://ftp.cs.tu-berlin.de/pub/local/kbs/tubmik/gsm/
 endef
 
+define Package/libgsm/description
+A GSM 06.10 full-rate speech transcoding implementation (library).
+       An implementation of the European GSM 06.10 provisional standard 
+       for full-rate speech transcoding, prI-ETS 300 036, which uses 
+       RPE/LTP (residual pulse excitation/long term prediction) coding 
+       at 13 kbit/s.
+endef
+
 define Package/gsm-utils
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+libgsm
   TITLE:=GSM transcoding utilities
-  DESCRIPTION:=A GSM 06.10 full-rate speech transcoding implementation (utilities).\\\
-    An implementation of the European GSM 06.10 provisional standard \\\
-    for full-rate speech transcoding, prI-ETS 300 036, which uses \\\
-    RPE/LTP (residual pulse excitation/long term prediction) coding \\\
-    at 13 kbit/s.
   URL:=ftp://ftp.cs.tu-berlin.de/pub/local/kbs/tubmik/gsm/
 endef
 
+define Package/gsm-utils/description
+A GSM 06.10 full-rate speech transcoding implementation (utilities).
+       An implementation of the European GSM 06.10 provisional standard 
+       for full-rate speech transcoding, prI-ETS 300 036, which uses 
+       RPE/LTP (residual pulse excitation/long term prediction) coding 
+       at 13 kbit/s.
+endef
+
 define Build/Configure
 endef
 
@@ -68,7 +73,7 @@ endef
 
 define Package/gsm-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
 endef
 
 define Build/InstallDev
@@ -78,11 +83,5 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgsm.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/gsm.h \
-               $(STAGING_DIR)/usr/lib/libgsm.{a,so*}
-endef
-
 $(eval $(call BuildPackage,libgsm))
 $(eval $(call BuildPackage,gsm-utils))