net/xtables-addons: update to version 1.31. this series of updates closes #8369
[openwrt/svn-archive/archive.git] / libs / gsm / Makefile
index 16795ee33b403ac32fac6277214f742ff6fbd69f..916105d260266f28fcade9bd5a31cf2ed84f7610 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,45 +8,53 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gsm
-PKG_VERSION:=1.0.10
-PKG_RELEASE:=3
+PKG_VERSION:=1.0.13
+PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.0-pl10
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.cs.tu-berlin.de/pub/local/kbs/tubmik/gsm/
-PKG_MD5SUM:=4b148480f82e96d274248e13880ec873
+PKG_SOURCE_URL:=http://user.cs.tu-berlin.de/~jutta/gsm/
+PKG_MD5SUM:=c1ba392ce61dc4aff1c29ea4e92f6df4
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.0-pl13
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/gsm/Default
+  TITLE:=GSM transcoding
+  URL:=http://user.cs.tu-berlin.de/~jutta/toast.html
+endef
+
+define Package/gsm/description/Default
+ An implementation of the European GSM 06.10 provisional standard 
+ for full-rate speech transcoding, prI-ETS 300 036, which uses 
+ RPE/LTP (residual pulse excitation/long term prediction) coding 
+ at 13 kbit/s.
+endef
+
 define Package/libgsm
+$(call Package/gsm/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=A GSM transcoding library
-  URL:=ftp://ftp.cs.tu-berlin.de/pub/local/kbs/tubmik/gsm/
+  TITLE+= library
 endef
 
 define Package/libgsm/description
-A GSM 06.10 full-rate speech transcoding implementation (library).
-       An implementation of the European GSM 06.10 provisional standard 
-       for full-rate speech transcoding, prI-ETS 300 036, which uses 
-       RPE/LTP (residual pulse excitation/long term prediction) coding 
-       at 13 kbit/s.
+$(call Package/gsm/description/Default)
+ This package contains a shared GSM transcoding library, used by other
+ programs.
 endef
 
 define Package/gsm-utils
+$(call Package/gsm/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+libgsm
-  TITLE:=GSM transcoding utilities
-  URL:=ftp://ftp.cs.tu-berlin.de/pub/local/kbs/tubmik/gsm/
+  TITLE+= utilities
 endef
 
 define Package/gsm-utils/description
-A GSM 06.10 full-rate speech transcoding implementation (utilities).
-       An implementation of the European GSM 06.10 provisional standard 
-       for full-rate speech transcoding, prI-ETS 300 036, which uses 
-       RPE/LTP (residual pulse excitation/long term prediction) coding 
-       at 13 kbit/s.
+$(call Package/gsm/description/Default)
+ This package contains GSM transcoding utilities.
 endef
 
 define Build/Configure
@@ -55,8 +63,6 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                LD="$(TARGET_CC)" \
@@ -72,14 +78,14 @@ endef
 
 define Package/gsm-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/toast $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/toast $(1)/usr/bin/
        (cd $(1)/usr/bin; ln -sf toast untoast; ln -sf toast tcat)
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include/gsm
+       $(INSTALL_DIR) $(1)/usr/include/gsm
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gsm.h $(1)/usr/include/gsm/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgsm.{a,so*} $(1)/usr/lib/
 endef